summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2021-07-07 15:01:37 +0200
committerMichael Howitz <mh@gocept.com>2021-07-07 15:01:37 +0200
commit02bf377521e3088c51a656ae00842732c0bb2385 (patch)
tree45fee477427461fb9ca4de793228183f3f6238db
parent9cad2e72e7f95d5127b03bce4b7ceec1b02f3e6c (diff)
downloadzope-i18nmessageid-02bf377521e3088c51a656ae00842732c0bb2385.tar.gz
Add support for Python 3.9.
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py6
-rw-r--r--src/zope/__init__.py2
3 files changed, 8 insertions, 4 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 48b1772..af30177 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,9 @@
5.0.2 (unreleased)
==================
-- Nothing changed yet.
+- Add support for Python 3.9.
+
+- Create wheels for aarch linux.
5.0.1 (2020-03-10)
diff --git a/setup.py b/setup.py
index 378e3bb..6eb8228 100644
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,7 @@ tests_require = [
'coverage',
]
+
def read(*rnames):
with open(os.path.join(os.path.dirname(__file__), *rnames)) as stream:
return stream.read()
@@ -66,6 +67,7 @@ class optional_build_ext(build_ext):
"""This class subclasses build_ext and allows
the building of C extensions to fail.
"""
+
def run(self):
try:
build_ext.run(self)
@@ -91,7 +93,6 @@ class optional_build_ext(build_ext):
print('*' * 80, file=sys.stderr)
-
setup(
name='zope.i18nmessageid',
version='5.0.2.dev0',
@@ -102,7 +103,7 @@ setup(
read('README.rst')
+ '\n\n' +
read('CHANGES.rst')
- ),
+ ),
keywords="zope i18n message factory",
classifiers=[
'Development Status :: 5 - Production/Stable',
@@ -117,6 +118,7 @@ setup(
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/src/zope/__init__.py b/src/zope/__init__.py
index 2cdb0e4..656dc0f 100644
--- a/src/zope/__init__.py
+++ b/src/zope/__init__.py
@@ -1 +1 @@
-__import__('pkg_resources').declare_namespace(__name__) # pragma: no cover
+__import__('pkg_resources').declare_namespace(__name__) # pragma: no cover