summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHanno Schlichting <hanno@hannosch.eu>2008-04-26 10:52:59 +0000
committerHanno Schlichting <hanno@hannosch.eu>2008-04-26 10:52:59 +0000
commitce43b238c42795633c85317efae4596644746b2e (patch)
treec8ddd010be68bcbf2e30078e096664aca4ab3384 /setup.py
parentfccf693012dc30606a3a04152d0fab43e46cd020 (diff)
downloadzope-i18n-ce43b238c42795633c85317efae4596644746b2e.tar.gz
Feature: Added optional automatic compilation of mo files from po files. You need to depend on the `zope.i18n [compile]` extra and set an environment variable called `zope.i18n.compile_mo_files` to any True value to enable this option. Bumped the package version to 3.5dev, as we added features and this is not a maintenance release anymore.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3084c4e..1bfeff9 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,7 @@ def read(*rnames):
setup(
name='zope.i18n',
- version = '3.4.1dev',
+ version = '3.5dev',
author='Zope Corporation and Contributors',
author_email='zope3-dev@zope.org',
description='Zope3 Internationalization Support',
@@ -58,4 +58,7 @@ setup(
],
include_package_data = True,
zip_safe = False,
+ extras_require = dict(
+ compile = ['pythongettext'],
+ ),
)