summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorWichert Akkerman <wichert@wiggy.net>2008-09-27 10:09:37 +0000
committerWichert Akkerman <wichert@wiggy.net>2008-09-27 10:09:37 +0000
commit7eb9502fe90aeda0ce39561d21f2c50ec865ca24 (patch)
tree7262a6ea0ffd1f5d646893c7ccb57f9bda3928d0 /setup.py
parent28cf15880ad79942a9ac2d3b70b26479c766fde1 (diff)
downloadzope-i18n-7eb9502fe90aeda0ce39561d21f2c50ec865ca24.tar.gz
Move the zcml support into an extra. This reduces the dependencies of a standard zope.i18n install by half a dozen packages.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5e00276..2779450 100644
--- a/setup.py
+++ b/setup.py
@@ -53,12 +53,13 @@ setup(
install_requires=['setuptools',
'pytz',
'zope.i18nmessageid',
- 'zope.component [zcml]',
+ 'zope.component',
'zope.configuration',
],
include_package_data = True,
zip_safe = False,
extras_require = dict(
compile = ['python-gettext'],
+ zcml = ['zope.component [zcml]'],
),
)