summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2019-07-10 15:51:29 +0300
committerGitHub <noreply@github.com>2019-07-10 15:51:29 +0300
commitb6f4f1710d34328f7d32eff692f6c61cd78bb455 (patch)
tree9d31f61bbaf2e48c5189d02733cf726bda9b2173
parent8b62b3b3592c3133b30e08d48e057cf248e20448 (diff)
parent2735e1e170e5f8c66275229573669b632c0a8b61 (diff)
downloadzope-i18n-b6f4f1710d34328f7d32eff692f6c61cd78bb455.tar.gz
Merge pull request #43 from zopefoundation/drop-py34
Drop Python 3.4 support
-rw-r--r--.coveragerc6
-rw-r--r--.travis.yml9
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py3
-rw-r--r--src/zope/i18n/tests/test_formats.py5
-rw-r--r--tox.ini18
6 files changed, 27 insertions, 18 deletions
diff --git a/.coveragerc b/.coveragerc
index b5cbda3..b5ae109 100644
--- a/.coveragerc
+++ b/.coveragerc
@@ -3,6 +3,12 @@ source = zope.i18n
omit =
*/flycheck_*py
+[paths]
+source =
+ src/
+ .tox/*/lib/python*/site-packages/
+ .tox/pypy*/site-packages/
+
[report]
precision = 2
exclude_lines =
diff --git a/.travis.yml b/.travis.yml
index b2ff47d..7dccb10 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,17 +1,12 @@
language: python
-sudo: false
+dist: xenial
python:
- 2.7
- - 3.4
- 3.5
- 3.6
+ - 3.7
- pypy
- pypy3
-matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index 2176760..5b38083 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,10 +2,10 @@
CHANGES
=========
-4.6.3 (unreleased)
+4.7.0 (unreleased)
==================
-- Nothing changed yet.
+- Drop Python 3.4 support.
4.6.2 (2019-02-19)
diff --git a/setup.py b/setup.py
index 3459e45..7116442 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,7 @@ TESTS_REQUIRE = COMPILE_REQUIRES + ZCML_REQUIRES + [
setup(
name='zope.i18n',
- version='4.6.3.dev0',
+ version='4.7.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Internationalization Support',
@@ -80,7 +80,6 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
diff --git a/src/zope/i18n/tests/test_formats.py b/src/zope/i18n/tests/test_formats.py
index 879a71a..83c9129 100644
--- a/src/zope/i18n/tests/test_formats.py
+++ b/src/zope/i18n/tests/test_formats.py
@@ -1039,6 +1039,7 @@ class TestNumberPatternParser(_TestCase):
(None, '', None, '0', '', '', None, '1', None, ()),
neg_pattern)
+
class TestNumberFormat(_TestCase):
"""Test the functionality of an implmentation of the NumberFormat."""
@@ -1326,6 +1327,10 @@ class TestNumberFormat(_TestCase):
self.format.format(-987654321, '+#,##,#0,000;-#,##,#0,000'),
'-98,76,54,321')
+ def testFormatBadThousandSeparator(self):
+ self.assertRaises(ValueError,
+ self.format.format, 23341, '0,')
+
def testFormatDecimal(self):
self.assertEqual(self.format.format(23341.02357, '###0.0#'),
'23341.02')
diff --git a/tox.ini b/tox.ini
index d4a3cf9..757b7d4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,25 +1,29 @@
[tox]
envlist =
- py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
+ py27,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
- zope-testrunner --test-path=src []
+ zope-testrunner --test-path=src {posargs:-pvc}
sphinx-build -b doctest -d {envdir}/doctrees docs {envdir}/doctest
-deps =
- .[test,docs,compile]
+extras =
+ test
+ docs
+ compile
[testenv:coverage]
usedevelop = true
basepython =
python3.6
commands =
- coverage run -m zope.testrunner --test-path=src []
- coverage run -a -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
+ coverage erase
+ coverage run -p -m zope.testrunner --test-path=src {posargs:-pvc}
+ coverage run -p -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
+ coverage combine
coverage report --fail-under=100
deps =
- {[testenv]deps}
coverage
+parallel_show_output = true
[testenv:docs]
basepython =