summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2019-07-10 15:12:01 +0300
committerMarius Gedminas <marius@gedmin.as>2019-07-10 15:12:01 +0300
commitaa750549a079358c5e489b91238e9db54121eb7b (patch)
treef79225ec460b38224c01645a1c0707d33e4ba1ec
parent8b62b3b3592c3133b30e08d48e057cf248e20448 (diff)
downloadzope-i18n-aa750549a079358c5e489b91238e9db54121eb7b.tar.gz
Drop Python 3.4 support
-rw-r--r--.travis.yml9
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py3
-rw-r--r--tox.ini14
4 files changed, 13 insertions, 17 deletions
diff --git a/.travis.yml b/.travis.yml
index b2ff47d..7dccb10 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,17 +1,12 @@
language: python
-sudo: false
+dist: xenial
python:
- 2.7
- - 3.4
- 3.5
- 3.6
+ - 3.7
- pypy
- pypy3
-matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index 2176760..5b38083 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,10 +2,10 @@
CHANGES
=========
-4.6.3 (unreleased)
+4.7.0 (unreleased)
==================
-- Nothing changed yet.
+- Drop Python 3.4 support.
4.6.2 (2019-02-19)
diff --git a/setup.py b/setup.py
index 3459e45..7116442 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,7 @@ TESTS_REQUIRE = COMPILE_REQUIRES + ZCML_REQUIRES + [
setup(
name='zope.i18n',
- version='4.6.3.dev0',
+ version='4.7.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Internationalization Support',
@@ -80,7 +80,6 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
diff --git a/tox.ini b/tox.ini
index d4a3cf9..c03bb9c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,25 +1,27 @@
[tox]
envlist =
- py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
+ py27,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
- zope-testrunner --test-path=src []
+ zope-testrunner --test-path=src {posargs:-pvc}
sphinx-build -b doctest -d {envdir}/doctrees docs {envdir}/doctest
-deps =
- .[test,docs,compile]
+extras =
+ test
+ docs
+ compile
[testenv:coverage]
usedevelop = true
basepython =
python3.6
commands =
- coverage run -m zope.testrunner --test-path=src []
+ coverage run -m zope.testrunner --test-path=src {posargs:-pvc}
coverage run -a -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
coverage report --fail-under=100
deps =
- {[testenv]deps}
coverage
+parallel_show_output = true
[testenv:docs]
basepython =