summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jk@gocept.com>2018-10-05 13:19:05 +0200
committerJeremy Kolbe <jk@gocept.com>2018-10-05 13:19:05 +0200
commitbd3e1c447fc38ad571979b84c1904ae0729b9507 (patch)
tree5aa64acdefc6223b7ef8803dc8aeb6f2962fce43
parentece19b3b7d984657019a896bdc5e3b407f75ac9e (diff)
downloadzope-i18n-Python3.7support.tar.gz
Add support for Python 3.7Python3.7support
-rw-r--r--.travis.yml5
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
4 files changed, 10 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index e770bda..b2ff47d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,11 @@ python:
- 3.6
- pypy
- pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index cd002c9..b7bd86b 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
4.3.2 (unreleased)
==================
-- Nothing changed yet.
+- Add support for Python 3.7.
4.3.1 (2017-12-19)
diff --git a/setup.py b/setup.py
index 8859443..980d991 100644
--- a/setup.py
+++ b/setup.py
@@ -83,6 +83,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 524de93..4c42d07 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -12,7 +12,7 @@ deps =
[testenv:coverage]
usedevelop = true
basepython =
- python3.6
+ python3.7
commands =
coverage run -m zope.testrunner --test-path=src []
coverage run -a -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
@@ -23,6 +23,6 @@ deps =
[testenv:docs]
basepython =
- python2.7
+ python3.6
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html