summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-09-11 11:28:00 -0500
committerJason Madden <jamadden@gmail.com>2017-09-11 11:28:00 -0500
commitcc9f097936226845a89d879d49f38894dd032d03 (patch)
tree3643ca6bc8d5d22d2c8927e0cb3686c5698075cf /setup.py
parentd97f1b37d541554ad85e15dd824a84d3e3883f4c (diff)
downloadzope-exceptions-cc9f097936226845a89d879d49f38894dd032d03.tar.gz
Fix non-ASCII supplement info under Python 2 and drop Py3.3.issue1
Fixes #1. Fix the coverage environment using zope.testrunner (nose no longer works, that same namespace path issue). Also run the doctests on all supported versions. This requires dropping Python 3.3 because sphinx needs 3.4+.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bc2e2d0..bdfdafa 100644
--- a/setup.py
+++ b/setup.py
@@ -61,7 +61,6 @@ setup(name='zope.exceptions',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
@@ -72,7 +71,7 @@ setup(name='zope.exceptions',
'Topic :: Internet :: WWW/HTTP',
'Framework :: Zope3',
],
- url='http://cheeseshop.python.org/pypi/zope.exceptions',
+ url='https://github.com/zopefoundation/zope.exceptions',
license='ZPL 2.1',
packages=find_packages('src'),
package_dir={'': 'src'},
@@ -89,7 +88,6 @@ setup(name='zope.exceptions',
zip_safe=False,
extras_require={
'docs': ['Sphinx', 'repoze.sphinx.autointerface'],
- 'testing': ['nose', 'coverage'],
'test': tests_require,
},
)