summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-26 15:41:37 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-26 15:41:37 -0500
commitc91e4766490e0853fb9cd151fe23a2f169087367 (patch)
tree12d42060b7e9d77c117e4db00ea5db7185f700e1
parent07b061e0dd0cf9fe083a3873d27ce39115345eaf (diff)
downloadzope-contenttype-c91e4766490e0853fb9cd151fe23a2f169087367.tar.gz
Add support for Python 3.4 and PyPy3.
-rw-r--r--.travis.yml4
-rw-r--r--CHANGES.rst6
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
4 files changed, 10 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 210c1e3..d409a1c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,9 +4,11 @@ python:
- 2.6
- 2.7
- 3.3
+ - 3.4
- pypy
+ - pypy3
install:
- - pip install . --use-mirrors
+ - pip install .
script:
- python setup.py test -q
notifications:
diff --git a/CHANGES.rst b/CHANGES.rst
index ccec9a9..247a594 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,9 +1,11 @@
Change History
==============
-4.0.2 (unreleased)
+4.1.0 (unreleased)
------------------
+- Add support for Python 3.4 and PyPy3.
+
- Add support for testing on Travis.
4.0.1 (2013-02-20)
@@ -19,7 +21,7 @@ Change History
- Add ``tox.ini`` and manifest.
-- Add support for Python 3.3 and PyPy 1.9.
+- Add support for Python 3.3 and PyPy.
- Drop support for Python 2.4 and 2.5.
diff --git a/setup.py b/setup.py
index 8c3b6cc..8812fc8 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ long_description = read('README.rst') + '\n' + read('CHANGES.rst')
setup(
name='zope.contenttype',
- version='4.0.2.dev0',
+ version='4.1.0.dev0',
url='http://pypi.python.org/pypi/zope.contenttype',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
@@ -46,6 +46,7 @@ setup(
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: OS Independent',
diff --git a/tox.ini b/tox.ini
index f78c53c..e5c6493 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py33,pypy
+ py26,py27,py33,py34,pypy,pypy3
[testenv]
commands =