summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2022-08-29 17:24:27 +0200
committerMichael Howitz <mh@gocept.com>2022-09-07 08:17:17 +0200
commit4856f858f251eb8cd37ee4196a34506d74bbac54 (patch)
tree2c19425132a3df482714fb5ee4a443e6bd8c2f3e
parenteeb26d081d6b66d97063e0df5320aa6c741170bd (diff)
downloadzope-contenttype-4856f858f251eb8cd37ee4196a34506d74bbac54.tar.gz
Add support for Python 3.9, 3.10; drop support for Python 3.4.
-rw-r--r--.meta.toml7
-rw-r--r--CHANGES.rst4
-rw-r--r--MANIFEST.in3
-rw-r--r--setup.py3
4 files changed, 15 insertions, 2 deletions
diff --git a/.meta.toml b/.meta.toml
index a1afcfb..7ae0c42 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -17,3 +17,10 @@ use-flake8 = true
[coverage]
fail-under = 100
+
+[manifest]
+additional-rules = [
+ "recursive-include src *.types",
+ "recursive-include src *.types-1",
+ "recursive-include src *.types-2",
+ ]
diff --git a/CHANGES.rst b/CHANGES.rst
index 654bbda..11c1d5b 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,9 @@
4.5.1 (unreleased)
==================
-- Nothing changed yet.
+- Add support for Python 3.9, 3.10.
+
+- Drop support for Python 3.4.
4.5.0 (2019-12-19)
diff --git a/MANIFEST.in b/MANIFEST.in
index 18bb4ff..c32d64d 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -12,3 +12,6 @@ recursive-include docs *.txt
recursive-include docs Makefile
recursive-include src *.py
+recursive-include src *.types
+recursive-include src *.types-1
+recursive-include src *.types-2
diff --git a/setup.py b/setup.py
index c3c31a8..5444487 100644
--- a/setup.py
+++ b/setup.py
@@ -51,11 +51,12 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: OS Independent',