summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-26 15:36:13 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-26 15:36:13 -0500
commit41c88845651b009c51033615e8476c91f0486aca (patch)
tree8fc97eaff7fb2cd4ad2b6c3f867c58ca47cbbee9
parentdd360efb446c5fb6ad5ba5e41b92e80d4f959852 (diff)
downloadzope-contenttype-41c88845651b009c51033615e8476c91f0486aca.tar.gz
Nest into Github.
-rw-r--r--CHANGES.rst (renamed from CHANGES.txt)0
-rw-r--r--README.rst8
-rw-r--r--README.txt6
-rw-r--r--setup.py12
4 files changed, 11 insertions, 15 deletions
diff --git a/CHANGES.txt b/CHANGES.rst
index b016f1c..b016f1c 100644
--- a/CHANGES.txt
+++ b/CHANGES.rst
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..cd50124
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,8 @@
+``zope.contenttype``
+====================
+
+.. image:: https://travis-ci.org/zopefoundation/zope.contenttype.png?branch=master
+ :target: https://travis-ci.org/zopefoundation/zope.contenttype
+
+A utility module for content-type handling.
+
diff --git a/README.txt b/README.txt
deleted file mode 100644
index f6bdff8..0000000
--- a/README.txt
+++ /dev/null
@@ -1,6 +0,0 @@
-zope.contenttype
-****************
-
-A utility module for content-type handling.
-
-.. contents::
diff --git a/setup.py b/setup.py
index d7f1aaa..8c3b6cc 100644
--- a/setup.py
+++ b/setup.py
@@ -24,16 +24,10 @@ import os
from setuptools import setup, find_packages
def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+ with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
+ return f.read()
-long_description = (
- read('README.txt')
- + '\n' +
- read('CHANGES.txt')
- + '\n' +
- 'Download\n'
- '********\n'
- )
+long_description = read('README.rst') + '\n' + read('CHANGES.rst')
setup(
name='zope.contenttype',