summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-04-12 16:12:26 -0400
committerTres Seaver <tseaver@palladion.com>2016-04-12 16:12:26 -0400
commit23b6815de7b666a72d9bba946469c0cee33acb52 (patch)
treeb4854ef8085a7065c9d6cb19d08f27360d68c5b1
parentafe262316a049942007c8242a54d6e668d175c86 (diff)
downloadzope-contenttype-23b6815de7b666a72d9bba946469c0cee33acb52.tar.gz
Add support for Python 3.5.add-py35-support
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
4 files changed, 5 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index f000d5e..2428b54 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,6 +4,7 @@ python:
- 2.7
- 3.3
- 3.4
+ - 3.5
- pypy
- pypy3
install:
diff --git a/CHANGES.rst b/CHANGES.rst
index 35c22a4..37cb799 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,8 @@ Change History
4.2.0 (unreleased)
------------------
+- Add support for Python 3.5.
+
- Drop support for Python 2.6.
4.1.0 (2014-12-26)
diff --git a/setup.py b/setup.py
index 675ab27..353c624 100644
--- a/setup.py
+++ b/setup.py
@@ -46,6 +46,7 @@ setup(
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: OS Independent',
diff --git a/tox.ini b/tox.ini
index 6a1f5c4..c359e1f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,12 +1,10 @@
[tox]
envlist =
- py27,py33,py34,pypy,pypy3,coverage
+ py27,py33,py34,py35,pypy,pypy3,coverage
[testenv]
commands =
python setup.py -q test -q
-# without explicit deps, setup.py test will download a bunch of eggs into $PWD
-deps =
[testenv:coverage]
usedevelop = true