summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-12-18 23:32:08 +0000
committerColin Watson <cjwatson@debian.org>2019-12-18 23:32:08 +0000
commit11231bb32b2dd602d99e75b4af8889d4b55ed996 (patch)
tree406eab655be23eeaef3ada218362864e7274a117
parent50a093ccdcfda8061eb66647af59ec9b14d644ea (diff)
downloadzope-contenttype-11231bb32b2dd602d99e75b4af8889d4b55ed996.tar.gz
Add support for Python 3.8
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
4 files changed, 6 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 5789a5e..33ac6d1 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,6 +6,7 @@ python:
- 3.5
- 3.6
- 3.7
+ - 3.8
- pypy
- pypy3
install:
diff --git a/CHANGES.rst b/CHANGES.rst
index c6f86f7..b724e57 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -8,6 +8,8 @@
- Fix tests on Python 3.8
(`#7 <https://github.com/zopefoundation/zope.contenttype/issues/7>`_).
+- Add support for Python 3.8.
+
4.4 (2018-10-05)
================
diff --git a/setup.py b/setup.py
index e0c37dd..fbb2945 100644
--- a/setup.py
+++ b/setup.py
@@ -52,6 +52,7 @@ setup(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: OS Independent',
diff --git a/tox.ini b/tox.ini
index 6b4a88d..e4db05c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,py37,pypy,pypy3,coverage
+ py27,py34,py35,py36,py37,py38,pypy,pypy3,coverage
[testenv]
commands =
@@ -11,7 +11,7 @@ deps =
[testenv:coverage]
usedevelop = true
basepython =
- python3.7
+ python3.8
commands =
coverage run -m zope.testrunner --test-path=src
coverage report --fail-under=100