summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jk@gocept.com>2018-10-05 13:23:17 +0200
committerJeremy Kolbe <jk@gocept.com>2018-10-05 13:23:17 +0200
commite3a6c3320250e8926b5ea3bbfc00d5225b57603f (patch)
tree436b1912183308d95ee9aca7abf32a259738fe3d
parent221729826ec3447b837330bff11b0db1dd9a8e4c (diff)
downloadzope-contenttype-Python3.7support.tar.gz
Add support for Python 3.7Python3.7support
-rw-r--r--.travis.yml7
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
4 files changed, 10 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index f44d718..80e6fd7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,12 @@ python:
- 3.5
- 3.6
- pypy
- - pypy3.5-5.8.0
+ - pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index 2551320..81a377e 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
4.3.1 (unreleased)
==================
-- Nothing changed yet.
+- Add support for Python 3.7.
4.3.0 (2017-08-10)
diff --git a/setup.py b/setup.py
index a9eb881..b91ed7b 100644
--- a/setup.py
+++ b/setup.py
@@ -51,6 +51,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: OS Independent',
diff --git a/tox.ini b/tox.ini
index eefe0cb..6b4a88d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage
[testenv]
commands =
@@ -11,7 +11,7 @@ deps =
[testenv:coverage]
usedevelop = true
basepython =
- python2.7
+ python3.7
commands =
coverage run -m zope.testrunner --test-path=src
coverage report --fail-under=100