summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2019-02-11 08:29:30 +0100
committerMichael Howitz <mh@gocept.com>2019-02-11 08:29:30 +0100
commitdb2119a636599c2d549d12ff7db6088c5b9e2ae8 (patch)
treeb1aefc643125e9636036a37496fb217743d34abd
parent89d7014caf2e0d02b67c08df39b3e3ec46fc7064 (diff)
downloadzope-configuration-db2119a636599c2d549d12ff7db6088c5b9e2ae8.tar.gz
Use skipping to show that setup.py cannot be found.
-rw-r--r--src/zope/configuration/tests/test_docs.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/zope/configuration/tests/test_docs.py b/src/zope/configuration/tests/test_docs.py
index f5283fd..f81de55 100644
--- a/src/zope/configuration/tests/test_docs.py
+++ b/src/zope/configuration/tests/test_docs.py
@@ -54,8 +54,14 @@ def test_suite():
prev, here = here, os.path.dirname(here)
if here == prev:
# Let's avoid infinite loops at root
- print('tests_doc.py: WARNING could not find setup.py -->'
- ' omitting documentation tests.') # pragma: no cover
+ class SkippedDocTests(unittest.TestCase): # pragma: no cover
+
+ @unittest.skip('Could not find setup.py')
+ def test_docs(self):
+ pass
+
+ suite.addTest(
+ unittest.makeSuite(SkippedDocTests)) # pragma: no cover
return suite # pragma: no cover
docs = os.path.join(here, 'docs')