summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2014-12-12 09:33:55 +0200
committerMarius Gedminas <marius@gedmin.as>2014-12-12 09:33:55 +0200
commita6c144983cb66f1cd6b03f27794abeaf316468d4 (patch)
tree13bcbc4cb04d40781f72fe5a4f3c649dae54d95f
parentd4f5b7d93c125d72c98c40691ecf2d7aa205b736 (diff)
downloadzope-component-a6c144983cb66f1cd6b03f27794abeaf316468d4.tar.gz
Make Travis CI run tox
Because 'python setup.py test' fails (and has always failed in Travis), and I've no time to debug. Also, I don't like duplicating test instructions in two places (tox.ini and .travis.yml).
-rw-r--r--.gitignore1
-rw-r--r--.travis.yml20
2 files changed, 13 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index 942dba1..ceb8f78 100644
--- a/.gitignore
+++ b/.gitignore
@@ -12,3 +12,4 @@ build
nosetests.xml
coverage.xml
.coverage
+dist/
diff --git a/.travis.yml b/.travis.yml
index 5eaf851..7cbcb72 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,13 +1,17 @@
language: python
-python:
- - 2.6
- - 2.7
- - 3.2
- - 3.3
- - pypy
+env:
+ - TOXENV=py26
+ - TOXENV=py26min
+ - TOXENV=py27
+ - TOXENV=py32
+ - TOXENV=py33
+ - TOXENV=py34
+ - TOXENV=pypy
+ - TOXENV=coverage
+ - TOXENV=docs
install:
- - pip install . --use-mirrors
+ - pip install tox
script:
- - python setup.py test -q
+ - tox
notifications:
email: false