summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini9
1 files changed, 4 insertions, 5 deletions
diff --git a/tox.ini b/tox.ini
index 9209c5a..1bb8a32 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,21 +4,20 @@ envlist =
[testenv]
commands =
- python setup.py -q test -q
+ zope-testrunner --test-path=src []
deps =
- zope.interface
+ .[test]
[testenv:coverage]
usedevelop = true
basepython =
python2.7
commands =
- nosetests --with-xunit --with-xcoverage
+ coverage run -m zope.testrunner --test-path=src
+ coverage report --fail-under=100
deps =
{[testenv]deps}
- nose
coverage
- nosexcover
[testenv:docs]
commands =