summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-08-04 08:18:27 -0500
committerJason Madden <jamadden@gmail.com>2017-08-04 08:18:27 -0500
commit6fe05f482e375849ad291718ae86be4025b70380 (patch)
treee51022b724b4744d22bad96ba056306d62423e25 /tox.ini
parentcae115125df33c4907c7a6a8a4c68b47a648a72e (diff)
downloadzope-browser-6fe05f482e375849ad291718ae86be4025b70380.tar.gz
Switch to zope.testrunner for namespace path issues.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini9
1 files changed, 4 insertions, 5 deletions
diff --git a/tox.ini b/tox.ini
index 9209c5a..1bb8a32 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,21 +4,20 @@ envlist =
[testenv]
commands =
- python setup.py -q test -q
+ zope-testrunner --test-path=src []
deps =
- zope.interface
+ .[test]
[testenv:coverage]
usedevelop = true
basepython =
python2.7
commands =
- nosetests --with-xunit --with-xcoverage
+ coverage run -m zope.testrunner --test-path=src
+ coverage report --fail-under=100
deps =
{[testenv]deps}
- nose
coverage
- nosexcover
[testenv:docs]
commands =