summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorStephan Richter <stephan.richter@gmail.com>2013-02-11 17:18:22 +0000
committerStephan Richter <stephan.richter@gmail.com>2013-02-11 17:18:22 +0000
commit2e73e919128477d8ca8da0ea23cdea66d9172fb6 (patch)
tree176c9a576f58789d915d3fdcc40860c883bacdbb /tox.ini
parent1a1495197547cde7f0f630b3df446d22f3abada9 (diff)
downloadzope-browser-2e73e919128477d8ca8da0ea23cdea66d9172fb6.tar.gz
Added Python 3.3 and PyPy support.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini25
1 files changed, 25 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..169878c
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,25 @@
+[tox]
+envlist =
+ py26,py27,py33,pypy
+
+[testenv]
+commands =
+ python setup.py test -q
+# without explicit deps, setup.py test will download a bunch of eggs into $PWD
+deps =
+ zope.interface
+
+[testenv:coverage]
+basepython =
+ python2.7
+commands =
+# The installed version messes up nose's test discovery / coverage reporting
+# So, we uninstall that from the environment, and then install the editable
+# version, before running nosetests.
+ pip uninstall -y zope.browser
+ pip install -e .
+ nosetests --with-xunit --with-xcoverage
+deps =
+ nose
+ coverage
+ nosexcover