summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2023-01-18 08:35:25 +0100
committerGitHub <noreply@github.com>2023-01-18 08:35:25 +0100
commit1944eef0b8bdd4b686ff441e0210537381714a4b (patch)
treef9b6a228d3913e666d15ad1af53179d40d0e9088 /tox.ini
parent1239c75e4e190df992bf34a88b4ead2c952afe86 (diff)
downloadzope-browser-1944eef0b8bdd4b686ff441e0210537381714a4b.tar.gz
Config with pure python template (#18)
* Drop support for Python 2.7, 3.5, 3.6. * Add support for Python 3.11.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini30
1 files changed, 18 insertions, 12 deletions
diff --git a/tox.ini b/tox.ini
index 2218f41..77a27b3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,14 +4,11 @@
minversion = 3.18
envlist =
lint
- py27
- py35
- py36
py37
py38
py39
py310
- pypy
+ py311
pypy3
docs
coverage
@@ -27,15 +24,26 @@ extras =
[testenv:lint]
basepython = python3
skip_install = true
+commands =
+ isort --check-only --diff {toxinidir}/src {toxinidir}/setup.py
+ flake8 src setup.py
+ check-manifest
+ check-python-versions
deps =
- flake8
check-manifest
check-python-versions >= 0.19.1
wheel
+ flake8
+ isort
+
+[testenv:isort-apply]
+basepython = python3
+skip_install = true
+commands_pre =
+deps =
+ isort
commands =
- flake8 src setup.py
- check-manifest
- check-python-versions
+ isort {toxinidir}/src {toxinidir}/setup.py []
[testenv:docs]
basepython = python3
@@ -52,16 +60,14 @@ allowlist_externals =
mkdir
deps =
coverage
- coverage-python-version
commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage run -m zope.testrunner --test-path=src {posargs:-vc}
- coverage html
- coverage report -m --fail-under=100
+ coverage html --ignore-errors
+ coverage report --ignore-errors --show-missing --fail-under=100
[coverage:run]
branch = True
-plugins = coverage_python_version
source = zope.browser
[coverage:report]