summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2009-05-13 20:53:38 +0000
committerTres Seaver <tseaver@palladion.com>2009-05-13 20:53:38 +0000
commitad77f8b236fc336049f5f82094ed84be258c592b (patch)
tree89779286225a4e1b3b35f6d53232058eda6692d4 /setup.py
parente4606fb77ec39f75f64954b22cdfdf90800a9387 (diff)
downloadzope-browser-ad77f8b236fc336049f5f82094ed84be258c592b.tar.gz
Prep 1.0 release.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py124
1 files changed, 62 insertions, 62 deletions
diff --git a/setup.py b/setup.py
index 32d4542..d095a0c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,62 +1,62 @@
-##############################################################################
-#
-# Copyright (c) 2006 Zope Corporation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-"""Setup for zope.browser package
-
-$Id:$
-"""
-
-import os
-
-from setuptools import setup, find_packages
-
-def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
-
-setup(name='zope.browser',
- version = '1.0dev',
- author='Zope Corporation and Contributors',
- author_email='zope3-dev@zope.org',
- description='Shared dependency less Zope 3 browser components',
- long_description=(
- read('README.txt')
- + '\n\n' +
- read('CHANGES.txt')
- ),
- license='ZPL 2.1',
- keywords = "zope3 browser component ITerms",
- classifiers = [
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: Zope Public License',
- 'Programming Language :: Python',
- 'Natural Language :: English',
- 'Operating System :: OS Independent',
- 'Topic :: Internet :: WWW/HTTP',
- 'Framework :: Zope3'],
- url='http://cheeseshop.python.org/pypi/zope.browser',
- packages=find_packages('src'),
- package_dir = {'': 'src'},
- namespace_packages=['zope',],
- extras_require = dict(
- test=[
- 'zope.testing',
- ]),
- install_requires=[
- 'setuptools',
- 'zope.interface',
- ],
- include_package_data = True,
- zip_safe = False,
- )
+##############################################################################
+#
+# Copyright (c) 2006 Zope Corporation and Contributors.
+# All Rights Reserved.
+#
+# This software is subject to the provisions of the Zope Public License,
+# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
+# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
+# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
+# FOR A PARTICULAR PURPOSE.
+#
+##############################################################################
+"""Setup for zope.browser package
+
+$Id:$
+"""
+
+import os
+
+from setuptools import setup, find_packages
+
+def read(*rnames):
+ return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+
+setup(name='zope.browser',
+ version = '1.0',
+ author='Zope Corporation and Contributors',
+ author_email='zope3-dev@zope.org',
+ description='Shared Zope Toolkit browser components',
+ long_description=(
+ read('README.txt')
+ + '\n\n' +
+ read('CHANGES.txt')
+ ),
+ license='ZPL 2.1',
+ keywords = "zope browser component",
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Zope Public License',
+ 'Programming Language :: Python',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Framework :: Zope3'],
+ url='http://cheeseshop.python.org/pypi/zope.browser',
+ packages=find_packages('src'),
+ package_dir = {'': 'src'},
+ namespace_packages=['zope',],
+ extras_require = dict(
+ test=[
+ 'zope.testing',
+ ]),
+ install_requires=[
+ 'setuptools',
+ 'zope.interface',
+ ],
+ include_package_data = True,
+ zip_safe = False,
+ )