summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-04-12 15:16:17 -0400
committerTres Seaver <tseaver@palladion.com>2016-04-12 15:16:17 -0400
commited1475086797daa7e812295f44994b57b4eed529 (patch)
tree7aab03cbda09e974719452422012f322d5e9c9c9
parentd281b9598c6be7225282f8420ec35de69f8caa0f (diff)
downloadzope-browser-ed1475086797daa7e812295f44994b57b4eed529.tar.gz
Add support for Python 3.5.add-py35-support
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini4
4 files changed, 6 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index f000d5e..2428b54 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,6 +4,7 @@ python:
- 2.7
- 3.3
- 3.4
+ - 3.5
- pypy
- pypy3
install:
diff --git a/CHANGES.rst b/CHANGES.rst
index 3b97590..f8ed148 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,8 @@ Changelog
2.2.0 (unreleased)
------------------
+- Add support for Python 3.5.
+
- Drop support for Python 2.6 and 3.2.
2.1.0 (2014-12-26)
diff --git a/setup.py b/setup.py
index 99178b3..adfee46 100644
--- a/setup.py
+++ b/setup.py
@@ -44,6 +44,7 @@ setup(name='zope.browser',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 8fec485..f7165cd 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,10 +1,10 @@
[tox]
envlist =
- py27,py33,py34,pypy,pypy3
+ py27,py33,py34,py35,pypy,pypy3
[testenv]
commands =
- python setup.py test -q
+ python setup.py -q test -q
deps =
zope.interface