summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-26 14:12:08 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-26 14:12:08 -0500
commitd633f48a42a11278f143dc12119a4796a61ab1ce (patch)
tree9096dbe94b584d289dfb3c1192d6e777a880cc55
parentaa30263455f8d9bfc9c18490dc8afe69b7167180 (diff)
downloadzope-browser-d633f48a42a11278f143dc12119a4796a61ab1ce.tar.gz
Add support for Python 3.4.
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
4 files changed, 8 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 11150b2..a733395 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,6 +4,8 @@ python:
- 2.6
- 2.7
- 3.3
+ - 3.4
+ - pypy
install:
- pip install . --use-mirrors
script:
diff --git a/CHANGES.rst b/CHANGES.rst
index fe0d1f3..e4605cd 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,9 +1,11 @@
Changelog
=========
-2.0.3 (unreleased)
+2.1.0 (unreleased)
------------------
+- Add support for Python 3.4.
+
- Add support for testing on Travis.
2.0.2 (2013-03-08)
diff --git a/setup.py b/setup.py
index ace1892..1cd1a5b 100644
--- a/setup.py
+++ b/setup.py
@@ -20,7 +20,7 @@ def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
setup(name='zope.browser',
- version='2.0.3.dev0',
+ version='2.1.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Shared Zope Toolkit browser components',
@@ -45,6 +45,7 @@ setup(name='zope.browser',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 9e21456..5735ec2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py32,py33,pypy
+ py26,py27,py32,py33,py34,pypy
[testenv]
commands =