summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-08-04 08:13:17 -0500
committerJason Madden <jamadden@gmail.com>2017-08-04 08:13:17 -0500
commitcae115125df33c4907c7a6a8a4c68b47a648a72e (patch)
tree6d941b324c519f12400380fd7741c88bf8ff6a49
parentcd2b9dfec498c2bc6b3a25fa4edc4c002acf129c (diff)
downloadzope-browser-cae115125df33c4907c7a6a8a4c68b47a648a72e.tar.gz
Publish docs to RTD
-rw-r--r--.gitignore2
-rw-r--r--CHANGES.rst27
-rw-r--r--MANIFEST.in5
-rw-r--r--README.rst20
-rw-r--r--docs-requirements.txt2
-rw-r--r--docs/Makefile225
-rw-r--r--docs/changelog.rst1
-rw-r--r--docs/conf.py370
-rw-r--r--docs/index.rst35
-rw-r--r--docs/interfaces.rst1
-rw-r--r--setup.py27
-rw-r--r--src/zope/browser/README.rst (renamed from src/zope/browser/README.txt)34
-rw-r--r--src/zope/browser/interfaces.py31
-rw-r--r--src/zope/browser/tests.py7
-rw-r--r--tox.ini8
15 files changed, 745 insertions, 50 deletions
diff --git a/.gitignore b/.gitignore
index 504f45b..5ea1c28 100644
--- a/.gitignore
+++ b/.gitignore
@@ -13,3 +13,5 @@ parts
.coverage
coverage.xml
nosetests.xml
+
+docs/_build/
diff --git a/CHANGES.rst b/CHANGES.rst
index f8ed148..e577766 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,32 +1,35 @@
-Changelog
-=========
+===========
+ Changelog
+===========
2.2.0 (unreleased)
-------------------
+==================
- Add support for Python 3.5.
- Drop support for Python 2.6 and 3.2.
+- Host documentation at https://zopebrowser.readthedocs.io
+
2.1.0 (2014-12-26)
-------------------
+==================
- Add support for Python 3.4.
- Add support for testing on Travis.
2.0.2 (2013-03-08)
-------------------
+==================
- Add Trove classifiers indicating CPython, 3.2 and PyPy support.
2.0.1 (2013-02-11)
-------------------
+==================
- Add support for testing with tox.
2.0.0 (2013-02-11)
-------------------
+==================
- Test coverage of 100% verified.
@@ -35,12 +38,12 @@ Changelog
- Drop support for Python 2.4 and 2.5.
1.3 (2010-04-30)
-----------------
+================
- Remove ``test`` extra and ``zope.testing`` dependency.
1.2 (2009-05-18)
-----------------
+================
- Move ``ISystemErrorView`` interface here from
``zope.app.exception`` to break undesirable dependencies.
@@ -50,19 +53,19 @@ Changelog
- Add doctests to ``long_description``.
1.1 (2009-05-13)
-----------------
+================
- Move ``IAdding`` interface here from ``zope.app.container.interfaces``
to break undesirable dependencies.
1.0 (2009-05-13)
-----------------
+================
- Move ``IView`` and ``IBrowserView`` interfaces here from
``zope.publisher.interfaces`` to break undesirable dependencies.
0.5.0 (2008-12-11)
-------------------
+==================
- Move ``ITerms`` interface here from ``zope.app.form.browser.interfaces``
to break undesirable dependencies.
diff --git a/MANIFEST.in b/MANIFEST.in
index 61dad0f..026ca84 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -3,7 +3,12 @@ include *.txt
include tox.ini
include bootstrap.py
include buildout.cfg
+include .travis.yml
+
recursive-include src *
+recursive-include docs *.py
+recursive-include docs *.rst
+recursive-include docs Makefile
global-exclude *.pyc
diff --git a/README.rst b/README.rst
index 49abf62..ac7a02c 100644
--- a/README.rst
+++ b/README.rst
@@ -1,7 +1,23 @@
-zope.browser
-============
+==============
+ zope.browser
+==============
.. image:: https://travis-ci.org/zopefoundation/zope.browser.png?branch=master
:target: https://travis-ci.org/zopefoundation/zope.browser
+.. image:: https://readthedocs.org/projects/zopesite/badge/?version=latest
+ :target: httpl://zopesite.readthedocs.io/en/latest/
+ :alt: Documentation Status
+
+
This package provides shared browser components for the Zope Toolkit.
+These components consist of a set of interfaces defining common
+concepts, including:
+
+- ``IView``
+- ``IBrowserView``
+- ``IAdding``
+- ``ITerms``
+- ``ISystemErrorView``
+
+Documentation is hosted at https://zopebrowser.readthedocs.io
diff --git a/docs-requirements.txt b/docs-requirements.txt
new file mode 100644
index 0000000..bcc3c8f
--- /dev/null
+++ b/docs-requirements.txt
@@ -0,0 +1,2 @@
+repoze.sphinx.autointerface
+sphinx_rtd_theme
diff --git a/docs/Makefile b/docs/Makefile
new file mode 100644
index 0000000..b44c7f7
--- /dev/null
+++ b/docs/Makefile
@@ -0,0 +1,225 @@
+# Makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+PAPER =
+BUILDDIR = _build
+
+# Internal variables.
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+# the i18n builder cannot share the environment and doctrees with the others
+I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+.PHONY: help
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " html to make standalone HTML files"
+ @echo " dirhtml to make HTML files named index.html in directories"
+ @echo " singlehtml to make a single large HTML file"
+ @echo " pickle to make pickle files"
+ @echo " json to make JSON files"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " qthelp to make HTML files and a qthelp project"
+ @echo " applehelp to make an Apple Help Book"
+ @echo " devhelp to make HTML files and a Devhelp project"
+ @echo " epub to make an epub"
+ @echo " epub3 to make an epub3"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " latexpdf to make LaTeX files and run them through pdflatex"
+ @echo " latexpdfja to make LaTeX files and run them through platex/dvipdfmx"
+ @echo " text to make text files"
+ @echo " man to make manual pages"
+ @echo " texinfo to make Texinfo files"
+ @echo " info to make Texinfo files and run them through makeinfo"
+ @echo " gettext to make PO message catalogs"
+ @echo " changes to make an overview of all changed/added/deprecated items"
+ @echo " xml to make Docutils-native XML files"
+ @echo " pseudoxml to make pseudoxml-XML files for display purposes"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+ @echo " coverage to run coverage check of the documentation (if enabled)"
+ @echo " dummy to check syntax errors of document sources"
+
+.PHONY: clean
+clean:
+ rm -rf $(BUILDDIR)/*
+
+.PHONY: html
+html:
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+.PHONY: dirhtml
+dirhtml:
+ $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
+
+.PHONY: singlehtml
+singlehtml:
+ $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
+ @echo
+ @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
+
+.PHONY: pickle
+pickle:
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files."
+
+.PHONY: json
+json:
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
+ @echo
+ @echo "Build finished; now you can process the JSON files."
+
+.PHONY: htmlhelp
+htmlhelp:
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+.PHONY: qthelp
+qthelp:
+ $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
+ @echo
+ @echo "Build finished; now you can run "qcollectiongenerator" with the" \
+ ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
+ @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/zcintid.qhcp"
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/zcintid.qhc"
+
+.PHONY: applehelp
+applehelp:
+ $(SPHINXBUILD) -b applehelp $(ALLSPHINXOPTS) $(BUILDDIR)/applehelp
+ @echo
+ @echo "Build finished. The help book is in $(BUILDDIR)/applehelp."
+ @echo "N.B. You won't be able to view it unless you put it in" \
+ "~/Library/Documentation/Help or install it in your application" \
+ "bundle."
+
+.PHONY: devhelp
+devhelp:
+ $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
+ @echo
+ @echo "Build finished."
+ @echo "To view the help file:"
+ @echo "# mkdir -p $$HOME/.local/share/devhelp/zcintid"
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/zcintid"
+ @echo "# devhelp"
+
+.PHONY: epub
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+.PHONY: epub3
+epub3:
+ $(SPHINXBUILD) -b epub3 $(ALLSPHINXOPTS) $(BUILDDIR)/epub3
+ @echo
+ @echo "Build finished. The epub3 file is in $(BUILDDIR)/epub3."
+
+.PHONY: latex
+latex:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make' in that directory to run these through (pdf)latex" \
+ "(use \`make latexpdf' here to do that automatically)."
+
+.PHONY: latexpdf
+latexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+.PHONY: latexpdfja
+latexpdfja:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through platex and dvipdfmx..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf-ja
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+.PHONY: text
+text:
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The text files are in $(BUILDDIR)/text."
+
+.PHONY: man
+man:
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
+ @echo
+ @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
+
+.PHONY: texinfo
+texinfo:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo
+ @echo "Build finished. The Texinfo files are in $(BUILDDIR)/texinfo."
+ @echo "Run \`make' in that directory to run these through makeinfo" \
+ "(use \`make info' here to do that automatically)."
+
+.PHONY: info
+info:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo "Running Texinfo files through makeinfo..."
+ make -C $(BUILDDIR)/texinfo info
+ @echo "makeinfo finished; the Info files are in $(BUILDDIR)/texinfo."
+
+.PHONY: gettext
+gettext:
+ $(SPHINXBUILD) -b gettext $(I18NSPHINXOPTS) $(BUILDDIR)/locale
+ @echo
+ @echo "Build finished. The message catalogs are in $(BUILDDIR)/locale."
+
+.PHONY: changes
+changes:
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+.PHONY: linkcheck
+linkcheck:
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+.PHONY: doctest
+doctest:
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."
+
+.PHONY: coverage
+coverage:
+ $(SPHINXBUILD) -b coverage $(ALLSPHINXOPTS) $(BUILDDIR)/coverage
+ @echo "Testing of coverage in the sources finished, look at the " \
+ "results in $(BUILDDIR)/coverage/python.txt."
+
+.PHONY: xml
+xml:
+ $(SPHINXBUILD) -b xml $(ALLSPHINXOPTS) $(BUILDDIR)/xml
+ @echo
+ @echo "Build finished. The XML files are in $(BUILDDIR)/xml."
+
+.PHONY: pseudoxml
+pseudoxml:
+ $(SPHINXBUILD) -b pseudoxml $(ALLSPHINXOPTS) $(BUILDDIR)/pseudoxml
+ @echo
+ @echo "Build finished. The pseudo-XML files are in $(BUILDDIR)/pseudoxml."
+
+.PHONY: dummy
+dummy:
+ $(SPHINXBUILD) -b dummy $(ALLSPHINXOPTS) $(BUILDDIR)/dummy
+ @echo
+ @echo "Build finished. Dummy builder generates no files."
diff --git a/docs/changelog.rst b/docs/changelog.rst
new file mode 100644
index 0000000..d9e113e
--- /dev/null
+++ b/docs/changelog.rst
@@ -0,0 +1 @@
+.. include:: ../CHANGES.rst
diff --git a/docs/conf.py b/docs/conf.py
new file mode 100644
index 0000000..976a4d7
--- /dev/null
+++ b/docs/conf.py
@@ -0,0 +1,370 @@
+# -*- coding: utf-8 -*-
+#
+# zope.app.apidoc documentation build configuration file, created by
+# sphinx-quickstart on Tue Sep 13 15:00:43 2016.
+#
+# This file is execfile()d with the current directory set to its
+# containing dir.
+#
+# Note that not all possible configuration values are present in this
+# autogenerated file.
+#
+# All configuration values have a default; values that are commented out
+# serve to show the default.
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+#
+# import os
+# import sys
+# sys.path.insert(0, os.path.abspath('.'))
+import os
+import sys
+import pkg_resources
+sys.path.append(os.path.abspath('../src'))
+rqmt = pkg_resources.require('zope.browser')[0]
+
+# -- General configuration ------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+#
+# needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
+# ones.
+extensions = [
+ 'sphinx.ext.autodoc',
+ 'sphinx.ext.intersphinx',
+ 'sphinx.ext.viewcode',
+ 'sphinx.ext.extlinks',
+ 'repoze.sphinx.autointerface',
+]
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ['_templates']
+
+# The suffix(es) of source filenames.
+# You can specify multiple suffix as a list of string:
+#
+# source_suffix = ['.rst', '.md']
+source_suffix = '.rst'
+
+# The encoding of source files.
+#
+# source_encoding = 'utf-8-sig'
+
+# The master toctree document.
+master_doc = 'index'
+
+# General information about the project.
+project = u'zope.browser'
+copyright = u'2017, Zope Community'
+author = u'Zope Community'
+
+# The version info for the project you're documenting, acts as replacement for
+# |version| and |release|, also used in various other places throughout the
+# built documents.
+#
+# The short X.Y version.
+version = '%s.%s' % tuple(map(int, rqmt.version.split('.')[:2]))
+# The full version, including alpha/beta/rc tags.
+release = rqmt.version
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+#
+# This is also used if you do content translation via gettext catalogs.
+# Usually you set "language" from the command line for these cases.
+language = None
+
+# There are two options for replacing |today|: either, you set today to some
+# non-false value, then it is used:
+#
+# today = ''
+#
+# Else, today_fmt is used as the format for a strftime call.
+#
+# today_fmt = '%B %d, %Y'
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+# This patterns also effect to html_static_path and html_extra_path
+exclude_patterns = ['_build', 'Thumbs.db', '.DS_Store']
+
+# The reST default role (used for this markup: `text`) to use for all
+# documents.
+#
+# default_role = None
+
+# If true, '()' will be appended to :func: etc. cross-reference text.
+#
+# add_function_parentheses = True
+
+# If true, the current module name will be prepended to all description
+# unit titles (such as .. function::).
+#
+# add_module_names = True
+
+# If true, sectionauthor and moduleauthor directives will be shown in the
+# output. They are ignored by default.
+#
+# show_authors = False
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = 'sphinx'
+
+# A list of ignored prefixes for module index sorting.
+# modindex_common_prefix = []
+
+# If true, keep warnings as "system message" paragraphs in the built documents.
+# keep_warnings = False
+
+# If true, `todo` and `todoList` produce output, else they produce nothing.
+todo_include_todos = False
+
+
+# -- Options for HTML output ----------------------------------------------
+
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+#
+html_theme = 'sphinx_rtd_theme'
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+#
+# html_theme_options = {}
+
+# Add any paths that contain custom themes here, relative to this directory.
+# html_theme_path = []
+
+# The name for this set of Sphinx documents.
+# "<project> v<release> documentation" by default.
+#
+# html_title = u'zope.browser vXXX'
+
+# A shorter title for the navigation bar. Default is the same as html_title.
+#
+# html_short_title = None
+
+# The name of an image file (relative to this directory) to place at the top
+# of the sidebar.
+#
+# html_logo = None
+
+# The name of an image file (relative to this directory) to use as a favicon of
+# the docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
+# pixels large.
+#
+# html_favicon = None
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = ['_static']
+
+# Add any extra paths that contain custom files (such as robots.txt or
+# .htaccess) here, relative to this directory. These files are copied
+# directly to the root of the documentation.
+#
+# html_extra_path = []
+
+# If not None, a 'Last updated on:' timestamp is inserted at every page
+# bottom, using the given strftime format.
+# The empty string is equivalent to '%b %d, %Y'.
+#
+# html_last_updated_fmt = None
+
+# If true, SmartyPants will be used to convert quotes and dashes to
+# typographically correct entities.
+#
+# html_use_smartypants = True
+
+# Custom sidebar templates, maps document names to template names.
+#
+# html_sidebars = {}
+
+# Additional templates that should be rendered to pages, maps page names to
+# template names.
+#
+# html_additional_pages = {}
+
+# If false, no module index is generated.
+#
+# html_domain_indices = True
+
+# If false, no index is generated.
+#
+# html_use_index = True
+
+# If true, the index is split into individual pages for each letter.
+#
+# html_split_index = False
+
+# If true, links to the reST sources are added to the pages.
+#
+# html_show_sourcelink = True
+
+# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
+#
+# html_show_sphinx = True
+
+# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
+#
+# html_show_copyright = True
+
+# If true, an OpenSearch description file will be output, and all pages will
+# contain a <link> tag referring to it. The value of this option must be the
+# base URL from which the finished HTML is served.
+#
+# html_use_opensearch = ''
+
+# This is the file name suffix for HTML files (e.g. ".xhtml").
+# html_file_suffix = None
+
+# Language to be used for generating the HTML full-text search index.
+# Sphinx supports the following languages:
+# 'da', 'de', 'en', 'es', 'fi', 'fr', 'hu', 'it', 'ja'
+# 'nl', 'no', 'pt', 'ro', 'ru', 'sv', 'tr', 'zh'
+#
+# html_search_language = 'en'
+
+# A dictionary with options for the search language support, empty by default.
+# 'ja' uses this config value.
+# 'zh' user can custom change `jieba` dictionary path.
+#
+# html_search_options = {'type': 'default'}
+
+# The name of a javascript file (relative to the configuration directory) that
+# implements a search results scorer. If empty, the default will be used.
+#
+# html_search_scorer = 'scorer.js'
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = 'zopebrowser'
+
+# -- Options for LaTeX output ---------------------------------------------
+
+latex_elements = {
+ # The paper size ('letterpaper' or 'a4paper').
+ #
+ # 'papersize': 'letterpaper',
+
+ # The font size ('10pt', '11pt' or '12pt').
+ #
+ # 'pointsize': '10pt',
+
+ # Additional stuff for the LaTeX preamble.
+ #
+ # 'preamble': '',
+
+ # Latex figure (float) alignment
+ #
+ # 'figure_align': 'htbp',
+}
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title,
+# author, documentclass [howto, manual, or own class]).
+latex_documents = [
+ (master_doc, 'zopebrowser.tex', u'zope.browser Documentation',
+ u'Zope Community', 'manual'),
+]
+
+# The name of an image file (relative to this directory) to place at the top of
+# the title page.
+#
+# latex_logo = None
+
+# For "manual" documents, if this is true, then toplevel headings are parts,
+# not chapters.
+#
+# latex_use_parts = False
+
+# If true, show page references after internal links.
+#
+# latex_show_pagerefs = False
+
+# If true, show URL addresses after external links.
+#
+# latex_show_urls = False
+
+# Documents to append as an appendix to all manuals.
+#
+# latex_appendices = []
+
+# It false, will not define \strong, \code, itleref, \crossref ... but only
+# \sphinxstrong, ..., \sphinxtitleref, ... To help avoid clash with user added
+# packages.
+#
+# latex_keep_old_macro_names = True
+
+# If false, no module index is generated.
+#
+# latex_domain_indices = True
+
+
+# -- Options for manual page output ---------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [
+ (master_doc, 'zopebrowser', u'zope.browser Documentation',
+ [author], 1)
+]
+
+# If true, show URL addresses after external links.
+#
+# man_show_urls = False
+
+
+# -- Options for Texinfo output -------------------------------------------
+
+# Grouping the document tree into Texinfo files. List of tuples
+# (source start file, target name, title, author,
+# dir menu entry, description, category)
+texinfo_documents = [
+ (master_doc, 'zopebrowser', u'zope.browser Documentation',
+ author, 'zopebrowser', 'One line description of project.',
+ 'Miscellaneous'),
+]
+
+# Documents to append as an appendix to all manuals.
+#
+# texinfo_appendices = []
+
+# If false, no module index is generated.
+#
+# texinfo_domain_indices = True
+
+# How to display URL addresses: 'footnote', 'no', or 'inline'.
+#
+# texinfo_show_urls = 'footnote'
+
+# If true, do not generate a @detailmenu in the "Top" node's menu.
+#
+# texinfo_no_detailmenu = False
+
+
+# Example configuration for intersphinx: refer to the Python standard library.
+intersphinx_mapping = {
+ 'https://docs.python.org/': None,
+ 'https://zopeinterface.readthedocs.io/en/latest': None,
+ 'https://zopecontainer.readthedocs.io/en/latest/': None,
+}
+
+extlinks = {'issue': ('https://github.com/zopefoundation/zope.browser/issues/%s',
+ 'issue #'),
+ 'pr': ('https://github.com/zopefoundation/zope.browser/pull/%s',
+ 'pull request #')}
+
+autodoc_default_flags = [
+ 'members',
+ 'show-inheritance',
+ 'special-members',
+]
+autoclass_content = 'both'
+autodoc_member_order = 'bysource'
diff --git a/docs/index.rst b/docs/index.rst
new file mode 100644
index 0000000..3793804
--- /dev/null
+++ b/docs/index.rst
@@ -0,0 +1,35 @@
+.. include:: ../README.rst
+
+.. toctree::
+ :maxdepth: 1
+
+ interfaces
+
+
+.. toctree::
+ :maxdepth: 2
+
+ changelog
+
+Development
+===========
+
+zope.browser is hosted at GitHub:
+
+ https://github.com/zopefoundation/zope.browser/
+
+
+
+Project URLs
+============
+
+* https://pypi.python.org/pypi/zope.browser (PyPI entry and downloads)
+
+
+====================
+ Indices and tables
+====================
+
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
diff --git a/docs/interfaces.rst b/docs/interfaces.rst
new file mode 100644
index 0000000..b7459c6
--- /dev/null
+++ b/docs/interfaces.rst
@@ -0,0 +1 @@
+.. include:: ../src/zope/browser/README.rst
diff --git a/setup.py b/setup.py
index adfee46..78a98fd 100644
--- a/setup.py
+++ b/setup.py
@@ -17,20 +17,20 @@ import os
from setuptools import setup, find_packages
def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+ with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
+ return f.read()
-setup(name='zope.browser',
+setup(
+ name='zope.browser',
version='2.2.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Shared Zope Toolkit browser components',
long_description=(
read('README.rst')
- + '\n\n.. contents::\n\n' +
- read('src', 'zope', 'browser', 'README.txt')
+ '\n\n' +
read('CHANGES.rst')
- ),
+ ),
license='ZPL 2.1',
keywords = "zope browser component",
classifiers = [
@@ -51,15 +51,22 @@ setup(name='zope.browser',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
'Framework :: Zope3'],
- url='http://pypi.python.org/pypi/zope.browser',
+ url='https://zopebrowser.readthedocs.io',
packages=find_packages('src'),
- package_dir = {'': 'src'},
+ package_dir={'': 'src'},
namespace_packages=['zope',],
install_requires=[
'setuptools',
'zope.interface',
+ ],
+ extras_require={
+ 'docs': [
+ 'Sphinx',
+ 'sphinx_rtd_theme',
+ 'repoze.sphinx.autointerface',
],
+ },
test_suite='zope.browser.tests.test_suite',
- include_package_data = True,
- zip_safe = False,
- )
+ include_package_data=True,
+ zip_safe=False,
+)
diff --git a/src/zope/browser/README.txt b/src/zope/browser/README.rst
index 5bb99b4..a13f15e 100644
--- a/src/zope/browser/README.txt
+++ b/src/zope/browser/README.rst
@@ -1,5 +1,13 @@
+============
+ Interfaces
+============
+
+This package defines several basic interfaces.
+
+.. currentmodule:: zope.browser.interfaces
+
IView
------
+=====
Views adapt both a context and a request.
@@ -11,14 +19,16 @@ and an interface:
>>> Interface.providedBy(IView)
True
+.. autointerface:: IView
+
IBrowserView
--------------
+============
Browser views are views specialized for requests from a browser (e.g.,
as distinct from WebDAV, FTP, XML-RPC, etc.).
There is not much we can test except that ``IBrowserView`` is importable
-and an interface derived from ``IView``:
+and an interface derived from :class:`IView`:
>>> from zope.interface import Interface
>>> from zope.browser.interfaces import IBrowserView
@@ -27,13 +37,15 @@ and an interface derived from ``IView``:
>>> IBrowserView.extends(IView)
True
+.. autointerface:: IBrowserView
+
IAdding
--------
+=======
Adding views manage how newly-created items get added to containers.
There is not much we can test except that ``IAdding`` is importable
-and an interface derived from ``IBrowserView``:
+and an interface derived from :class:`IBrowserView`:
>>> from zope.interface import Interface
>>> from zope.browser.interfaces import IAdding
@@ -42,8 +54,10 @@ and an interface derived from ``IBrowserView``:
>>> IAdding.extends(IBrowserView)
True
+.. autointerface:: IAdding
+
ITerms
-------
+======
The ``ITerms`` interface is used as a base for ``ISource`` widget
implementations. This interfaces get used by ``zope.app.form`` and was
@@ -62,17 +76,21 @@ and an interface:
>>> Interface.providedBy(ITerms)
True
+.. autointerface:: ITerms
+
ISystemErrorView
-----------------
+================
Views providing this interface can classify their contexts as system
errors. These errors can be handled in a special way (e. g. more
detailed logging).
-There is not much we can test except that ISystemErrorView is importable
+There is not much we can test except that ``ISystemErrorView`` is importable
and an interface:
>>> from zope.interface import Interface
>>> from zope.browser.interfaces import ISystemErrorView
>>> Interface.providedBy(ISystemErrorView)
True
+
+.. autointerface:: ISystemErrorView
diff --git a/src/zope/browser/interfaces.py b/src/zope/browser/interfaces.py
index a7c0188..ff956c5 100644
--- a/src/zope/browser/interfaces.py
+++ b/src/zope/browser/interfaces.py
@@ -27,35 +27,36 @@ class IView(Interface):
class IBrowserView(IView):
""" Views which are specialized for requests from a browser
- o Such views are distinct from those geerated via WebDAV, FTP, XML-RPC,
- etc..
+ Such views are distinct from those geerated via WebDAV, FTP, XML-RPC,
+ etc.
"""
class IAdding(IBrowserView):
""" Multi-adapter interface for views which add items to containers.
- o The 'context' of the view must implement ``zope.container.IContainer``.
+ The 'context' of the view must implement :obj:`zope.container.interfaces.IContainer`.
"""
+
def add(content):
"""Add content object to context.
- Add using the name in `contentName`.
+ Add using the name in ``contentName``.
Return the added object in the context of its container.
- If `contentName` is already used in container, raise
- ``zope.container.interfaces.DuplicateIDError``.
+ If ``contentName`` is already used in container, raise
+ :class:`zope.container.interfaces.DuplicateIDError`.
"""
contentName = Attribute(
- """The content name, usually set by the Adder traverser.
+ """The content name, usually set by the Adder traverser.
- If the content name hasn't been defined yet, returns ``None``.
+ If the content name hasn't been defined yet, returns ``None``.
- Some creation views might use this to optionally display the
- name on forms.
- """
- )
+ Some creation views might use this to optionally display the
+ name on forms.
+ """
+ )
def nextURL():
"""Return the URL that the creation view should redirect to.
@@ -82,7 +83,7 @@ class IAdding(IBrowserView):
"""Return whether there is single menu item or not."""
def hasCustomAddView():
- "This should be called only if there is `singleMenuItem` else return 0"
+ "This should be called only if there is ``singleMenuItem`` else return 0"
class ITerms(Interface):
@@ -91,7 +92,9 @@ class ITerms(Interface):
def getTerm(value):
"""Return an ITitledTokenizedTerm object for the given value
- LookupError is raised if the value isn't in the source
+ LookupError is raised if the value isn't in the source.
+
+ The return value should have the ``token`` and ``title`` attributes.
"""
def getValue(token):
diff --git a/src/zope/browser/tests.py b/src/zope/browser/tests.py
index 6df50d2..a58fe7d 100644
--- a/src/zope/browser/tests.py
+++ b/src/zope/browser/tests.py
@@ -18,10 +18,11 @@ import unittest
def test_suite():
return unittest.TestSuite((
- doctest.DocFileSuite('README.txt',
+ doctest.DocFileSuite(
+ 'README.rst',
optionflags=doctest.NORMALIZE_WHITESPACE|doctest.ELLIPSIS,
- ),
- ))
+ ),
+ ))
if __name__ == '__main__':
diff --git a/tox.ini b/tox.ini
index f7165cd..9209c5a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py33,py34,py35,pypy,pypy3
+ py27,py33,py34,py35,pypy,pypy3,docs
[testenv]
commands =
@@ -19,3 +19,9 @@ deps =
nose
coverage
nosexcover
+
+[testenv:docs]
+commands =
+ sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
+deps =
+ .[docs]