summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-08-04 08:20:03 -0500
committerJason Madden <jamadden@gmail.com>2017-08-04 08:20:03 -0500
commita8f79d6fb622ab67a8630da2651cc184caa917f1 (patch)
tree87c583aad786e40b3364794e22ab627faa16d4b5
parent6fe05f482e375849ad291718ae86be4025b70380 (diff)
downloadzope-browser-a8f79d6fb622ab67a8630da2651cc184caa917f1.tar.gz
Drop Python 3.3 and add Python 3.6docs
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 5 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 0bdca86..f44d718 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,9 +2,9 @@ language: python
sudo: false
python:
- 2.7
- - 3.3
- 3.4
- 3.5
+ - 3.6
- pypy
- pypy3.5-5.8.0
install:
diff --git a/CHANGES.rst b/CHANGES.rst
index e577766..3d24ccd 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,9 +5,9 @@
2.2.0 (unreleased)
==================
-- Add support for Python 3.5.
+- Add support for Python 3.5 and 3.6.
-- Drop support for Python 2.6 and 3.2.
+- Drop support for Python 2.6, 3.2 and 3.3.
- Host documentation at https://zopebrowser.readthedocs.io
diff --git a/setup.py b/setup.py
index e685020..4bad774 100644
--- a/setup.py
+++ b/setup.py
@@ -42,9 +42,9 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 1bb8a32..2442718 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py33,py34,py35,pypy,pypy3,docs
+ py27,py34,py35,py36,pypy,pypy3,docs,coverage
[testenv]
commands =