summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@gmail.com>2015-03-10 17:46:42 -0700
committerJoshua Harlow <harlowja@gmail.com>2015-03-10 17:46:42 -0700
commit436bab3306aeec420f1281f34bd5d26d7f81038c (patch)
treef71c202bad6f840baa86437d5452b748def00d84
parent5eee5a7c0cb5a9c3f12d146b380cf826f377cb91 (diff)
parent4f7e57969a0a189d7d64890d8f5115b89f900e7d (diff)
downloadzake-436bab3306aeec420f1281f34bd5d26d7f81038c.tar.gz
Merge pull request #15 from yahoo/fix-test-requirements0.2.1
Fix test requirements
-rw-r--r--.travis.yml2
-rwxr-xr-xsetup.py3
-rw-r--r--test-requirements.txt3
-rw-r--r--tox.ini3
4 files changed, 6 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 3cfcbee..5a0ba77 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,7 +7,7 @@ python:
# command to install dependencies
install:
- "pip install ."
- - "pip install nose"
+ - "pip install -r test-requirements.txt"
# command to run tests
script: nosetests
diff --git a/setup.py b/setup.py
index 2d4c726..a495433 100755
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ with open("README.rst", "r") as readme:
setup(
name='zake',
- version='0.2.0',
+ version='0.2.1',
description='A python package that works to provide a nice set of '
'testing utilities for the kazoo library.',
author="Joshua Harlow",
@@ -36,7 +36,6 @@ setup(
install_requires=[
'kazoo',
'six',
- 'testtools',
],
classifiers=[
"Development Status :: 4 - Beta",
diff --git a/test-requirements.txt b/test-requirements.txt
new file mode 100644
index 0000000..50b9bae
--- /dev/null
+++ b/test-requirements.txt
@@ -0,0 +1,3 @@
+nose
+testtools
+flake8
diff --git a/tox.ini b/tox.ini
index 9b346a7..061c08f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -6,8 +6,7 @@ skipsdist = True
usedevelop = True
install_command = pip install {opts} {packages}
setenv = VIRTUAL_ENV={envdir}
-deps = nose
- flake8
+deps = -r{toxinidir}/test-requirements.txt
commands = nosetests {posargs}
[testenv:pep8]