summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2015-03-10 17:39:28 -0700
committerJoshua Harlow <harlowja@yahoo-inc.com>2015-03-10 17:42:37 -0700
commit215620ca51c3c883279ba62ccc860a274219ecc1 (patch)
treeaa0adfbdee22dbe035cbc6988244979588d7adb0
parentf4c4fb6428478edd54e638a09fb70a58064aa907 (diff)
downloadzake-215620ca51c3c883279ba62ccc860a274219ecc1.tar.gz
Remove testtools as an install requirement
Testtools is a test requirement and isn't needed at zake usage time, so it should be in its own test-requirements file.
-rw-r--r--.travis.yml2
-rwxr-xr-xsetup.py1
-rw-r--r--test-requirements.txt3
-rw-r--r--tox.ini3
4 files changed, 5 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 3cfcbee..5a0ba77 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,7 +7,7 @@ python:
# command to install dependencies
install:
- "pip install ."
- - "pip install nose"
+ - "pip install -r test-requirements.txt"
# command to run tests
script: nosetests
diff --git a/setup.py b/setup.py
index 2d4c726..29a60dc 100755
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,6 @@ setup(
install_requires=[
'kazoo',
'six',
- 'testtools',
],
classifiers=[
"Development Status :: 4 - Beta",
diff --git a/test-requirements.txt b/test-requirements.txt
new file mode 100644
index 0000000..50b9bae
--- /dev/null
+++ b/test-requirements.txt
@@ -0,0 +1,3 @@
+nose
+testtools
+flake8
diff --git a/tox.ini b/tox.ini
index 9b346a7..061c08f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -6,8 +6,7 @@ skipsdist = True
usedevelop = True
install_command = pip install {opts} {packages}
setenv = VIRTUAL_ENV={envdir}
-deps = nose
- flake8
+deps = -r{toxinidir}/test-requirements.txt
commands = nosetests {posargs}
[testenv:pep8]