summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..13cbddf
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,14 @@
+[tool.cibuildwheel]
+test-requires = "pytest"
+test-command = "pytest {project}/xattr/tests"
+
+[tool.cibuildwheel.linux]
+before-all = "yum install -y libffi-devel"
+
+[[tool.cibuildwheel.overrides]]
+select = "*-manylinux2_*"
+before-all = "apt-get -y install libffi-dev"
+
+[[tool.cibuildwheel.overrides]]
+select = "*-musllinux*"
+before-all = "apk add libffi-dev" \ No newline at end of file