summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2014-03-27 08:35:34 -0700
committerBob Ippolito <bob@redivi.com>2014-03-27 08:35:34 -0700
commitdd10d44e3eb9a1d2303c1f7d5126c099d56e97fc (patch)
tree5a18fa53915169d77784b3b1b92eba3ca66ca528
parent70d1ad2caf11e8dbdef9bc0dcdd2c3702d70b607 (diff)
downloadxattr-dd10d44e3eb9a1d2303c1f7d5126c099d56e97fc.tar.gz
fix Python 3 compatibility and prep for v0.7.6v0.7.6
-rw-r--r--CHANGES.txt5
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
-rw-r--r--xattr/tests/test_xattr.py7
4 files changed, 11 insertions, 5 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index a432829..4bae368 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,8 @@
+Version 0.7.6 released 2014-03-27
+
+* Fixed Solaris & Solaris Studio support and Python 2.6 compatibility
+ https://github.com/xattr/xattr/pull/29
+
Version 0.7.5 released 2014-03-23
* Improved error message when str/unicode is passed where bytes is
diff --git a/setup.py b/setup.py
index d071dd7..8a560d7 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ class cffi_build(build):
self.distribution.ext_modules = [ffi.verifier.get_extension()]
build.finalize_options(self)
-VERSION = '0.7.5'
+VERSION = '0.7.6'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index 883a46d..de02f72 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.7.5'
+__version__ = '0.7.6'
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,
XATTR_NOSECURITY, XATTR_MAXNAMELEN, XATTR_FINDERINFO_NAME,
diff --git a/xattr/tests/test_xattr.py b/xattr/tests/test_xattr.py
index bd201b7..f96ba30 100644
--- a/xattr/tests/test_xattr.py
+++ b/xattr/tests/test_xattr.py
@@ -18,8 +18,8 @@ class BaseTestXattr(object):
d['SUNWattr_ro'] = x['SUNWattr_ro']
d['SUNWattr_rw'] = x['SUNWattr_rw']
- self.assertEqual(x.keys(), d.keys())
- self.assertEqual(x.list(), d.keys())
+ self.assertEqual(list(x.keys()), list(d.keys()))
+ self.assertEqual(list(x.list()), list(d.keys()))
self.assertEqual(dict(x), d)
x['user.sopal'] = b'foo'
@@ -60,7 +60,8 @@ class BaseTestXattr(object):
try:
assign()
- except TypeError, e:
+ except TypeError:
+ e = sys.exc_info()[1]
self.assertEqual(str(e), msg)
def test_symlink_attrs(self):