summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2022-10-24 09:27:38 -0700
committerGitHub <noreply@github.com>2022-10-24 09:27:38 -0700
commitc1cda54172775a0b726fe40a737533d2d3bfe956 (patch)
tree8d4732bdd71639c6fe686228cbc72cb6d09e46ad
parent1ef829a69eb06f505cc56d6a0ff278a559606bc1 (diff)
parent83b5811c6c3dfc9e0c3c688f4751a7b2e7bb81f1 (diff)
downloadxattr-c1cda54172775a0b726fe40a737533d2d3bfe956.tar.gz
Merge pull request #107 from xattr/release-v0.10.0v0.10.0
Update version to v0.10.0
-rw-r--r--CHANGES.txt9
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
3 files changed, 11 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index be23d5b..6ee427d 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,12 @@
+Version 0.10.0 released 2022-10-24
+
+* Remove exec flag from tool.py
+ https://github.com/xattr/xattr/pull/106
+* Update the documentation to mention
+ the attr package and its getfattr and
+ setfattr tools
+ https://github.com/xattr/xattr/pull/103
+
Version 0.9.9 released 2021-12-11
* Fix regression in xattr console script
diff --git a/setup.py b/setup.py
index b9e51ff..022be38 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ import sys
from setuptools import setup
-VERSION = '0.9.9'
+VERSION = '0.10.0'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index 68f47ca..cea7817 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.9.9'
+__version__ = '0.10.0'
from .compat import integer_types
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,