summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2018-07-31 10:01:06 -0700
committerGitHub <noreply@github.com>2018-07-31 10:01:06 -0700
commit4782f6770b38bd7ac4cc6957f5becda12dc4541a (patch)
tree13b8201233eca81ae737f24081d4b355971da2d5
parent35cf2178da5e11d4beb3534fb364f1221a635550 (diff)
parent728671673a8da8f12aeb87098a8d232d3ffc2eeb (diff)
downloadxattr-4782f6770b38bd7ac4cc6957f5becda12dc4541a.tar.gz
Merge pull request #79 from xattr/travis-test-sdist
Attempt to add a test for sdist completeness
-rwxr-xr-x.travis/run.sh8
-rw-r--r--CHANGES.txt1
2 files changed, 9 insertions, 0 deletions
diff --git a/.travis/run.sh b/.travis/run.sh
index 25cbf7d..da22855 100755
--- a/.travis/run.sh
+++ b/.travis/run.sh
@@ -22,4 +22,12 @@ if [[ -n "$PYENV_VERSION" && $TRAVIS_OS_NAME == 'osx' ]]; then
fi
if [[ $BUILD_SDIST == 'true' ]]; then
python setup.py sdist
+ mkdir -p tmp-build
+ cd tmp-build
+ tar zxvf ../dist/xattr-*.tar.gz
+ cd xattr-*
+ "$cmd" setup.py build_ext -i
+ "$cmd" setup.py test
+ cd ../..
+ rm -rf tmp-build
fi
diff --git a/CHANGES.txt b/CHANGES.txt
index 58a06c7..6599a54 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -2,6 +2,7 @@ Version 0.9.5 released 2018-07-31
* Fix release build by including *.[ch] in Manifest.in
https://github.com/xattr/xattr/pull/77
+ https://github.com/xattr/xattr/pull/78
Version 0.9.4 released 2018-07-30