summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2021-12-11 07:55:13 -0800
committerBob Ippolito <bob@redivi.com>2021-12-11 07:55:13 -0800
commita9f6657d876524eaffda4bd05adc523e2226b8f2 (patch)
treed321b22e01278977d11d4a06bffa42db58415d41
parenta642aa35e0f3d8c150808dc746716706e26bc836 (diff)
downloadxattr-fix-xattr-console-script.tar.gz
Fix regression in xattr console scriptfix-xattr-console-script
-rw-r--r--CHANGES.txt9
-rw-r--r--setup.py2
-rw-r--r--xattr/__init__.py2
-rwxr-xr-xxattr/tool.py2
4 files changed, 12 insertions, 3 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 0db3bd2..be23d5b 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,12 @@
+Version 0.9.9 released 2021-12-11
+
+* Fix regression in xattr console script
+ https://github.com/xattr/xattr/pull/100
+* Add -c clear option
+ https://github.com/xattr/xattr/pull/98
+* Add note about Linux namespace requirement
+ https://github.com/xattr/xattr/pull/96
+
Version 0.9.8 released 2021-11-19
* Update build to use Github Actions
diff --git a/setup.py b/setup.py
index 928ab2a..b9e51ff 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ import sys
from setuptools import setup
-VERSION = '0.9.8'
+VERSION = '0.9.9'
DESCRIPTION = "Python wrapper for extended filesystem attributes"
LONG_DESCRIPTION = """
Extended attributes extend the basic attributes of files and directories
diff --git a/xattr/__init__.py b/xattr/__init__.py
index 4e5a517..68f47ca 100644
--- a/xattr/__init__.py
+++ b/xattr/__init__.py
@@ -7,7 +7,7 @@ The xattr type wraps a path or file descriptor with a dict-like interface
that exposes these extended attributes.
"""
-__version__ = '0.9.8'
+__version__ = '0.9.9'
from .compat import integer_types
from .lib import (XATTR_NOFOLLOW, XATTR_CREATE, XATTR_REPLACE,
diff --git a/xattr/tool.py b/xattr/tool.py
index d9548e1..d3a361a 100755
--- a/xattr/tool.py
+++ b/xattr/tool.py
@@ -89,7 +89,7 @@ def _dump(src, length=16):
return ''.join(result)
-def main(argv):
+def main(argv=sys.argv):
try:
(optargs, args) = getopt.getopt(argv[1:], "hlpwdzsc", ["help"])
except getopt.GetoptError as e: