summaryrefslogtreecommitdiff
path: root/tox-tmpl.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox-tmpl.ini')
-rw-r--r--tox-tmpl.ini34
1 files changed, 16 insertions, 18 deletions
diff --git a/tox-tmpl.ini b/tox-tmpl.ini
index 69502df..692b570 100644
--- a/tox-tmpl.ini
+++ b/tox-tmpl.ini
@@ -1,6 +1,6 @@
# content of: tox.ini , put in same dir as setup.py
[tox]
-envlist = py27,py27-nolxml,pypy,tg11,tg15,cornice,cornice-py3,coverage,py35,py35-nolxml,pecan-dev27,pecan-dev35,pep8
+envlist = py27,py27-nolxml,pypy,cornice,cornice-py3,coverage,py36,py35,py36-nolxml,py35-nolxml,pecan-dev27,pecan-dev35,pecan-dev36,pep8
[common]
testtools=
@@ -15,10 +15,10 @@ basedeps=
Sphinx < 1.2.99
Flask
flask-restful
+ SQLAlchemy<=0.7.99
[axes]
-python=py27,py35,pypy
-sqlalchemy=sa5,sa6,sa7*
+python=py27,py35,py36,pypy
lxml=lxml*,nolxml
json=json*,simplejson
@@ -30,7 +30,6 @@ deps =
commands=
{envbindir}/coverage run {envbindir}/nosetests --nologcapture --with-xunit --xunit-file nosetests-{envname}.xml wsme/tests wsmeext/tests tests/pecantest tests/test_sphinxext.py tests/test_flask.py --verbose {posargs}
- {envbindir}/coverage xml -o coverage-{envname}.xml wsme/*.py wsme/rest/*.py wsmeext/*.py
{envbindir}/coverage report --show-missing wsme/*.py wsme/rest/*.py wsmeext/*.py
[axis:python:py27]
@@ -39,17 +38,8 @@ basepython=python2.7
[axis:python:py35]
basepython=python3.5
-[axis:sqlalchemy:sa5]
-deps=
- SQLAlchemy<=0.5.99
-
-[axis:sqlalchemy:sa6]
-deps=
- SQLAlchemy<=0.6.99
-
-[axis:sqlalchemy:sa7]
-deps=
- SQLAlchemy<=0.7.99
+[axis:python:py36]
+basepython=python3.6
[axis:json:simplejson]
deps=
@@ -77,7 +67,7 @@ commands=
{envbindir}/coverage xml -o coverage-{envname}.xml wsme/*.py wsmeext/cornice.py
[testenv:cornice-py3]
-basepython = python3.5
+basepython = python3.6
usedevelop = {[testenv:cornice]usedevelop}
deps = {[testenv:cornice]deps}
# disable hash randomization
@@ -92,7 +82,7 @@ deps=
{[common]testtools}
transaction
suds-jurko
- https://github.com/stackforge/pecan/zipball/master
+ https://github.com/pecan/pecan/zipball/master
[testenv:pecan-dev27]
basepython=python2.7
@@ -106,8 +96,14 @@ deps={[testenv:pecan-dev-base]deps}
commands=
{envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+[testenv:pecan-dev36]
+basepython=python3.6
+deps={[testenv:pecan-dev-base]deps}
+commands=
+ {envbindir}/nosetests tests/pecantest --with-xunit --xunit-file nosetests-{envname}.xml --verbose {posargs}
+
[testenv:coverage]
-basepython=python
+basepython=python3
deps=
coverage < 3.99
setenv=
@@ -119,6 +115,7 @@ commands=
{envbindir}/coverage report --show-missing wsme/*.py wsme/protocols/*.py wsmeext/*.py
[testenv:doc]
+basepython=python3
deps=
cloud_sptheme
Sphinx < 1.2.99
@@ -130,6 +127,7 @@ commands=
make clean ziphtml
[testenv:pep8]
+basepython=python3
deps = flake8
commands = flake8 wsme wsmeext setup.py