summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile153
-rw-r--r--docs/api.rst30
-rw-r--r--docs/conf.py242
-rw-r--r--docs/index.rst225
-rw-r--r--docs/make.bat190
-rw-r--r--docs/story.rst62
6 files changed, 0 insertions, 902 deletions
diff --git a/docs/Makefile b/docs/Makefile
deleted file mode 100644
index 54b44f9..0000000
--- a/docs/Makefile
+++ /dev/null
@@ -1,153 +0,0 @@
-# Makefile for Sphinx documentation
-#
-
-# You can set these variables from the command line.
-SPHINXOPTS =
-SPHINXBUILD = sphinx-build
-PAPER =
-BUILDDIR = _build
-
-# Internal variables.
-PAPEROPT_a4 = -D latex_paper_size=a4
-PAPEROPT_letter = -D latex_paper_size=letter
-ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
-# the i18n builder cannot share the environment and doctrees with the others
-I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
-
-.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest gettext
-
-help:
- @echo "Please use \`make <target>' where <target> is one of"
- @echo " html to make standalone HTML files"
- @echo " dirhtml to make HTML files named index.html in directories"
- @echo " singlehtml to make a single large HTML file"
- @echo " pickle to make pickle files"
- @echo " json to make JSON files"
- @echo " htmlhelp to make HTML files and a HTML help project"
- @echo " qthelp to make HTML files and a qthelp project"
- @echo " devhelp to make HTML files and a Devhelp project"
- @echo " epub to make an epub"
- @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
- @echo " latexpdf to make LaTeX files and run them through pdflatex"
- @echo " text to make text files"
- @echo " man to make manual pages"
- @echo " texinfo to make Texinfo files"
- @echo " info to make Texinfo files and run them through makeinfo"
- @echo " gettext to make PO message catalogs"
- @echo " changes to make an overview of all changed/added/deprecated items"
- @echo " linkcheck to check all external links for integrity"
- @echo " doctest to run all doctests embedded in the documentation (if enabled)"
-
-clean:
- -rm -rf $(BUILDDIR)/*
-
-html:
- $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
- @echo
- @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
-
-dirhtml:
- $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
- @echo
- @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
-
-singlehtml:
- $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
- @echo
- @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
-
-pickle:
- $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
- @echo
- @echo "Build finished; now you can process the pickle files."
-
-json:
- $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
- @echo
- @echo "Build finished; now you can process the JSON files."
-
-htmlhelp:
- $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
- @echo
- @echo "Build finished; now you can run HTML Help Workshop with the" \
- ".hhp project file in $(BUILDDIR)/htmlhelp."
-
-qthelp:
- $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
- @echo
- @echo "Build finished; now you can run "qcollectiongenerator" with the" \
- ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
- @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/wheel.qhcp"
- @echo "To view the help file:"
- @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/wheel.qhc"
-
-devhelp:
- $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
- @echo
- @echo "Build finished."
- @echo "To view the help file:"
- @echo "# mkdir -p $$HOME/.local/share/devhelp/wheel"
- @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/wheel"
- @echo "# devhelp"
-
-epub:
- $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
- @echo
- @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
-
-latex:
- $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
- @echo
- @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
- @echo "Run \`make' in that directory to run these through (pdf)latex" \
- "(use \`make latexpdf' here to do that automatically)."
-
-latexpdf:
- $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
- @echo "Running LaTeX files through pdflatex..."
- $(MAKE) -C $(BUILDDIR)/latex all-pdf
- @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
-
-text:
- $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
- @echo
- @echo "Build finished. The text files are in $(BUILDDIR)/text."
-
-man:
- $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
- @echo
- @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
-
-texinfo:
- $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
- @echo
- @echo "Build finished. The Texinfo files are in $(BUILDDIR)/texinfo."
- @echo "Run \`make' in that directory to run these through makeinfo" \
- "(use \`make info' here to do that automatically)."
-
-info:
- $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
- @echo "Running Texinfo files through makeinfo..."
- make -C $(BUILDDIR)/texinfo info
- @echo "makeinfo finished; the Info files are in $(BUILDDIR)/texinfo."
-
-gettext:
- $(SPHINXBUILD) -b gettext $(I18NSPHINXOPTS) $(BUILDDIR)/locale
- @echo
- @echo "Build finished. The message catalogs are in $(BUILDDIR)/locale."
-
-changes:
- $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
- @echo
- @echo "The overview file is in $(BUILDDIR)/changes."
-
-linkcheck:
- $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
- @echo
- @echo "Link check complete; look for any errors in the above output " \
- "or in $(BUILDDIR)/linkcheck/output.txt."
-
-doctest:
- $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
- @echo "Testing of doctests in the sources finished, look at the " \
- "results in $(BUILDDIR)/doctest/output.txt."
diff --git a/docs/api.rst b/docs/api.rst
deleted file mode 100644
index 152b2f5..0000000
--- a/docs/api.rst
+++ /dev/null
@@ -1,30 +0,0 @@
-API Documentation
-=================
-
-wheel.archive
--------------
-
-.. automodule:: wheel.archive
- :members:
-
-
-wheel.install
--------------
-
-.. automodule:: wheel.install
- :members:
-
-
-wheel.pkginfo
--------------
-
-.. automodule:: wheel.pkginfo
- :members:
-
-
-wheel.util
-----------
-
-.. automodule:: wheel.util
- :members:
-
diff --git a/docs/conf.py b/docs/conf.py
deleted file mode 100644
index 62b1001..0000000
--- a/docs/conf.py
+++ /dev/null
@@ -1,242 +0,0 @@
-# -*- coding: utf-8 -*-
-#
-# wheel documentation build configuration file, created by
-# sphinx-quickstart on Thu Jul 12 00:14:09 2012.
-#
-# This file is execfile()d with the current directory set to its containing dir.
-#
-# Note that not all possible configuration values are present in this
-# autogenerated file.
-#
-# All configuration values have a default; values that are commented out
-# serve to show the default.
-
-import sys, os, pkg_resources
-
-# If extensions (or modules to document with autodoc) are in another directory,
-# add these directories to sys.path here. If the directory is relative to the
-# documentation root, use os.path.abspath to make it absolute, like shown here.
-#sys.path.insert(0, os.path.abspath('.'))
-
-# -- General configuration -----------------------------------------------------
-
-# If your documentation needs a minimal Sphinx version, state it here.
-#needs_sphinx = '1.0'
-
-# Add any Sphinx extension module names here, as strings. They can be extensions
-# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
-extensions = ['sphinx.ext.autodoc']
-
-# Add any paths that contain templates here, relative to this directory.
-templates_path = ['_templates']
-
-# The suffix of source filenames.
-source_suffix = '.rst'
-
-# The encoding of source files.
-#source_encoding = 'utf-8-sig'
-
-# The master toctree document.
-master_doc = 'index'
-
-# General information about the project.
-project = u'wheel'
-copyright = u'2012, Daniel Holth'
-
-# The version info for the project you're documenting, acts as replacement for
-# |version| and |release|, also used in various other places throughout the
-# built documents.
-#
-# The short X.Y version.
-version = pkg_resources.working_set.by_key['wheel'].version
-# The full version, including alpha/beta/rc tags.
-release = version
-
-# The language for content autogenerated by Sphinx. Refer to documentation
-# for a list of supported languages.
-#language = None
-
-# There are two options for replacing |today|: either, you set today to some
-# non-false value, then it is used:
-#today = ''
-# Else, today_fmt is used as the format for a strftime call.
-#today_fmt = '%B %d, %Y'
-
-# List of patterns, relative to source directory, that match files and
-# directories to ignore when looking for source files.
-exclude_patterns = ['_build']
-
-# The reST default role (used for this markup: `text`) to use for all documents.
-#default_role = None
-
-# If true, '()' will be appended to :func: etc. cross-reference text.
-#add_function_parentheses = True
-
-# If true, the current module name will be prepended to all description
-# unit titles (such as .. function::).
-#add_module_names = True
-
-# If true, sectionauthor and moduleauthor directives will be shown in the
-# output. They are ignored by default.
-#show_authors = False
-
-# The name of the Pygments (syntax highlighting) style to use.
-pygments_style = 'sphinx'
-
-# A list of ignored prefixes for module index sorting.
-#modindex_common_prefix = []
-
-
-# -- Options for HTML output ---------------------------------------------------
-
-# The theme to use for HTML and HTML Help pages. See the documentation for
-# a list of builtin themes.
-html_theme = 'default'
-
-# Theme options are theme-specific and customize the look and feel of a theme
-# further. For a list of options available for each theme, see the
-# documentation.
-#html_theme_options = {}
-
-# Add any paths that contain custom themes here, relative to this directory.
-#html_theme_path = []
-
-# The name for this set of Sphinx documents. If None, it defaults to
-# "<project> v<release> documentation".
-#html_title = None
-
-# A shorter title for the navigation bar. Default is the same as html_title.
-#html_short_title = None
-
-# The name of an image file (relative to this directory) to place at the top
-# of the sidebar.
-#html_logo = None
-
-# The name of an image file (within the static path) to use as favicon of the
-# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
-# pixels large.
-#html_favicon = None
-
-# Add any paths that contain custom static files (such as style sheets) here,
-# relative to this directory. They are copied after the builtin static files,
-# so a file named "default.css" will overwrite the builtin "default.css".
-html_static_path = ['_static']
-
-# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
-# using the given strftime format.
-#html_last_updated_fmt = '%b %d, %Y'
-
-# If true, SmartyPants will be used to convert quotes and dashes to
-# typographically correct entities.
-#html_use_smartypants = True
-
-# Custom sidebar templates, maps document names to template names.
-#html_sidebars = {}
-
-# Additional templates that should be rendered to pages, maps page names to
-# template names.
-#html_additional_pages = {}
-
-# If false, no module index is generated.
-#html_domain_indices = True
-
-# If false, no index is generated.
-#html_use_index = True
-
-# If true, the index is split into individual pages for each letter.
-#html_split_index = False
-
-# If true, links to the reST sources are added to the pages.
-#html_show_sourcelink = True
-
-# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
-#html_show_sphinx = True
-
-# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
-#html_show_copyright = True
-
-# If true, an OpenSearch description file will be output, and all pages will
-# contain a <link> tag referring to it. The value of this option must be the
-# base URL from which the finished HTML is served.
-#html_use_opensearch = ''
-
-# This is the file name suffix for HTML files (e.g. ".xhtml").
-#html_file_suffix = None
-
-# Output file base name for HTML help builder.
-htmlhelp_basename = 'wheeldoc'
-
-
-# -- Options for LaTeX output --------------------------------------------------
-
-latex_elements = {
-# The paper size ('letterpaper' or 'a4paper').
-#'papersize': 'letterpaper',
-
-# The font size ('10pt', '11pt' or '12pt').
-#'pointsize': '10pt',
-
-# Additional stuff for the LaTeX preamble.
-#'preamble': '',
-}
-
-# Grouping the document tree into LaTeX files. List of tuples
-# (source start file, target name, title, author, documentclass [howto/manual]).
-latex_documents = [
- ('index', 'wheel.tex', u'wheel Documentation',
- u'Daniel Holth', 'manual'),
-]
-
-# The name of an image file (relative to this directory) to place at the top of
-# the title page.
-#latex_logo = None
-
-# For "manual" documents, if this is true, then toplevel headings are parts,
-# not chapters.
-#latex_use_parts = False
-
-# If true, show page references after internal links.
-#latex_show_pagerefs = False
-
-# If true, show URL addresses after external links.
-#latex_show_urls = False
-
-# Documents to append as an appendix to all manuals.
-#latex_appendices = []
-
-# If false, no module index is generated.
-#latex_domain_indices = True
-
-
-# -- Options for manual page output --------------------------------------------
-
-# One entry per manual page. List of tuples
-# (source start file, name, description, authors, manual section).
-man_pages = [
- ('index', 'wheel', u'wheel Documentation',
- [u'Daniel Holth'], 1)
-]
-
-# If true, show URL addresses after external links.
-#man_show_urls = False
-
-
-# -- Options for Texinfo output ------------------------------------------------
-
-# Grouping the document tree into Texinfo files. List of tuples
-# (source start file, target name, title, author,
-# dir menu entry, description, category)
-texinfo_documents = [
- ('index', 'wheel', u'wheel Documentation',
- u'Daniel Holth', 'wheel', 'One line description of project.',
- 'Miscellaneous'),
-]
-
-# Documents to append as an appendix to all manuals.
-#texinfo_appendices = []
-
-# If false, no module index is generated.
-#texinfo_domain_indices = True
-
-# How to display URL addresses: 'footnote', 'no', or 'inline'.
-#texinfo_show_urls = 'footnote'
diff --git a/docs/index.rst b/docs/index.rst
deleted file mode 100644
index f1dbce6..0000000
--- a/docs/index.rst
+++ /dev/null
@@ -1,225 +0,0 @@
-.. wheel documentation master file, created by
- sphinx-quickstart on Thu Jul 12 00:14:09 2012.
- You can adapt this file completely to your liking, but it should at least
- contain the root `toctree` directive.
-
-.. include:: ../README.txt
-
-Usage
------
-
-The current version of wheel can be used to speed up repeated
-installations by reducing the number of times you have to compile your
-software. When you are creating a virtualenv for each revision of your
-software the savings can be dramatic. This example packages pyramid
-and all its dependencies as wheels, and then installs pyramid from the
-built packages::
-
- # Make sure you have the latest pip that supports wheel
- pip install --upgrade pip
-
- # Install wheel
- pip install wheel
-
- # Build a directory of wheels for pyramid and all its dependencies
- pip wheel --wheel-dir=/tmp/wheelhouse pyramid
-
- # Install from cached wheels
- pip install --use-wheel --no-index --find-links=/tmp/wheelhouse pyramid
-
- # Install from cached wheels remotely
- pip install --use-wheel --no-index --find-links=https://wheelhouse.example.com/ pyramid
-
-
-For lxml, an up to 3-minute "search for the newest version and compile"
-can become a less-than-1 second "unpack from wheel".
-
-As a side effect the wheel directory, "/tmp/wheelhouse" in the example,
-contains installable copies of the exact versions of your application's
-dependencies. By installing from those cached wheels
-you can recreate that environment quickly and with no surprises.
-
-To build an individual wheel, run ``python setup.py bdist_wheel``. Note that
-``bdist_wheel`` only works with distribute (``import setuptools``); plain
-``distutils`` does not support pluggable commands like ``bdist_wheel``. On
-the other hand ``pip`` always runs ``setup.py`` with setuptools enabled.
-
-Wheel also includes its own installer that can only install wheels (not
-sdists) from a local file or folder, but has the advantage of working
-even when distribute or pip has not been installed.
-
-Wheel's builtin utility can be invoked directly from wheel's own wheel::
-
- $ python wheel-0.21.0-py2.py3-none-any.whl/wheel -h
- usage: wheel [-h]
-
- {keygen,sign,unsign,verify,unpack,install,install-scripts,convert,help}
- ...
-
- positional arguments:
- {keygen,sign,unsign,verify,unpack,install,install-scripts,convert,help}
- commands
- keygen Generate signing key
- sign Sign wheel
- unsign Remove RECORD.jws from a wheel by truncating the zip
- file. RECORD.jws must be at the end of the archive.
- The zip file must be an ordinary archive, with the
- compressed files and the directory in the same order,
- and without any non-zip content after the truncation
- point.
- verify Verify a wheel. The signature will be verified for
- internal consistency ONLY and printed. Wheel's own
- unpack/install commands verify the manifest against
- the signature and file contents.
- unpack Unpack wheel
- install Install wheels
- install-scripts Install console_scripts
- convert Convert egg or wininst to wheel
- help Show this help
-
- optional arguments:
- -h, --help show this help message and exit
-
-Setuptools scripts handling
----------------------------
-
-Setuptools' popular `console_scripts` and `gui_scripts` entry points can
-be used to generate platform-specific scripts wrappers. Most usefully
-these wrappers include `.exe` launchers if they are generated on a
-Windows machine.
-
-As of 0.23.0, `bdist_wheel` no longer places pre-generated versions of these
-wrappers into the `*.data/scripts/` directory of the archive (non-setuptools
-scripts are still present, of course).
-
-If the scripts are needed, use a real installer like `pip`. The wheel tool
-`python -m wheel install-scripts package [package ...]` can also be used at
-any time to call setuptools to write the appropriate scripts wrappers.
-
-Defining the Python version
----------------------------
-
-The `bdist_wheel` command automatically determines the correct tags to use for
-the generated wheel. These are based on the Python interpreter used to
-generate the wheel and whether the project contains C extension code or not.
-While this is usually correct for C code, it can be too conservative for pure
-Python code. The bdist_wheel command therefore supports two flags that can be
-used to specify the Python version tag to use more precisely::
-
- --universal Specifies that a pure-python wheel is "universal"
- (i.e., it works on any version of Python). This
- equates to the tag "py2.py3".
- --python-tag XXX Specifies the precise python version tag to use for
- a pure-python wheel.
- --py-limited-api {cp32|cp33|cp34|...}
- Specifies Python Py_LIMITED_API compatibility with
- the version of CPython passed and later versions.
- The wheel will be tagged cpNN.abi3.{arch} on CPython 3.
- This flag does not affect Python 2 builds or alternate
- Python implementations.
-
- To conform to the limited API, all your C
- extensions must use only functions from the limited
- API, pass Extension(py_limited_api=True) and e.g.
- #define Py_LIMITED_API=0x03020000 depending on
- the exact minimun Python you wish to support.
-
-The --universal and --python-tag flags have no effect when used on a
-project that includes C extension code.
-
-The default for a pure Python project (if no explicit flags are given) is "pyN"
-where N is the major version of the Python interpreter used to build the wheel.
-This is generally the correct choice, as projects would not typically ship
-different wheels for different minor versions of Python.
-
-A reasonable use of the `--python-tag` argument would be for a project that
-uses Python syntax only introduced in a particular Python version. There are
-no current examples of this, but if wheels had been available when Python 2.5
-was released (the first version containing the `with` statement), wheels for a
-project that used the `with` statement would typically use `--python-tag py25`.
-However, unless a separate version of the wheel was shipped which avoided the
-use of the new syntax, there is little benefit in explicitly marking the tag in
-this manner.
-
-Typically, projects would not specify Python tags on the command line, but
-would use `setup.cfg` to set them as a project default::
-
- [bdist_wheel]
- universal=1
-
-or::
-
- [bdist_wheel]
- python-tag = py32
-
-Defining conditional dependencies
----------------------------------
-
-In wheel, the only way to have conditional dependencies (that might only be
-needed on certain platforms) is to use environment markers as defined by
-PEP 426.
-
-As of wheel 0.24.0, the recommended way to do this is in the setuptools
-`extras_require` parameter. A `:` separates the extra name from the marker.
-Wheel's own setup.py has an example::
- extras_require={
- ':python_version=="2.6"': ['argparse'],
- 'signatures': ['keyring'],
- 'signatures:sys_platform!="win32"': ['pyxdg'],
- 'faster-signatures': ['ed25519ll'],
- 'tool': []
- },
-
-The extra named '' signifies a default requirement, as if it was passed to
-`install_requires`.
-
-Older versions of bdist_wheel supported passing requirements in a
-now-deprecated [metadata] section in setup.cfg.
-
-Automatically sign wheel files
-------------------------------
-
-Wheel contains an experimental digital signatures scheme based on Ed25519
-signatures; these signatures are unrelated to pgp/gpg signatures and do not
-include a trust model.
-
-`python setup.py bdist_wheel` will automatically sign wheel files if
-the environment variable `WHEEL_TOOL` is set to the path of the `wheel`
-command line tool.::
-
- # Install the wheel tool and its dependencies
- $ pip install wheel[tool]
- # Generate a signing key (only once)
- $ wheel keygen
-
- $ export WHEEL_TOOL=/path/to/wheel
- $ python setup.py bdist_wheel
-
-Signing is done in a subprocess because it is not convenient for the
-build environment to contain bindings to the keyring and cryptography
-libraries. The keyring library may not be able to find your keys (choosing
-a different key storage back end based on available dependencies) unless
-you run it from the same environment used for keygen.
-
-Format
-------
-
-The wheel format is documented as PEP 427 "The Wheel Binary Package
-Format..." (http://www.python.org/dev/peps/pep-0427/).
-
-Slogans
--------
-
-Wheel
-
-* Because ‘newegg’ was taken.
-* Python packaging - reinvented.
-* A container for cheese.
-* It makes it easier to roll out software.
-
-.. toctree::
- :maxdepth: 2
-
- story
- api
-
diff --git a/docs/make.bat b/docs/make.bat
deleted file mode 100644
index 8083236..0000000
--- a/docs/make.bat
+++ /dev/null
@@ -1,190 +0,0 @@
-@ECHO OFF
-
-REM Command file for Sphinx documentation
-
-if "%SPHINXBUILD%" == "" (
- set SPHINXBUILD=sphinx-build
-)
-set BUILDDIR=_build
-set ALLSPHINXOPTS=-d %BUILDDIR%/doctrees %SPHINXOPTS% .
-set I18NSPHINXOPTS=%SPHINXOPTS% .
-if NOT "%PAPER%" == "" (
- set ALLSPHINXOPTS=-D latex_paper_size=%PAPER% %ALLSPHINXOPTS%
- set I18NSPHINXOPTS=-D latex_paper_size=%PAPER% %I18NSPHINXOPTS%
-)
-
-if "%1" == "" goto help
-
-if "%1" == "help" (
- :help
- echo.Please use `make ^<target^>` where ^<target^> is one of
- echo. html to make standalone HTML files
- echo. dirhtml to make HTML files named index.html in directories
- echo. singlehtml to make a single large HTML file
- echo. pickle to make pickle files
- echo. json to make JSON files
- echo. htmlhelp to make HTML files and a HTML help project
- echo. qthelp to make HTML files and a qthelp project
- echo. devhelp to make HTML files and a Devhelp project
- echo. epub to make an epub
- echo. latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter
- echo. text to make text files
- echo. man to make manual pages
- echo. texinfo to make Texinfo files
- echo. gettext to make PO message catalogs
- echo. changes to make an overview over all changed/added/deprecated items
- echo. linkcheck to check all external links for integrity
- echo. doctest to run all doctests embedded in the documentation if enabled
- goto end
-)
-
-if "%1" == "clean" (
- for /d %%i in (%BUILDDIR%\*) do rmdir /q /s %%i
- del /q /s %BUILDDIR%\*
- goto end
-)
-
-if "%1" == "html" (
- %SPHINXBUILD% -b html %ALLSPHINXOPTS% %BUILDDIR%/html
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The HTML pages are in %BUILDDIR%/html.
- goto end
-)
-
-if "%1" == "dirhtml" (
- %SPHINXBUILD% -b dirhtml %ALLSPHINXOPTS% %BUILDDIR%/dirhtml
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The HTML pages are in %BUILDDIR%/dirhtml.
- goto end
-)
-
-if "%1" == "singlehtml" (
- %SPHINXBUILD% -b singlehtml %ALLSPHINXOPTS% %BUILDDIR%/singlehtml
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The HTML pages are in %BUILDDIR%/singlehtml.
- goto end
-)
-
-if "%1" == "pickle" (
- %SPHINXBUILD% -b pickle %ALLSPHINXOPTS% %BUILDDIR%/pickle
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished; now you can process the pickle files.
- goto end
-)
-
-if "%1" == "json" (
- %SPHINXBUILD% -b json %ALLSPHINXOPTS% %BUILDDIR%/json
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished; now you can process the JSON files.
- goto end
-)
-
-if "%1" == "htmlhelp" (
- %SPHINXBUILD% -b htmlhelp %ALLSPHINXOPTS% %BUILDDIR%/htmlhelp
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished; now you can run HTML Help Workshop with the ^
-.hhp project file in %BUILDDIR%/htmlhelp.
- goto end
-)
-
-if "%1" == "qthelp" (
- %SPHINXBUILD% -b qthelp %ALLSPHINXOPTS% %BUILDDIR%/qthelp
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished; now you can run "qcollectiongenerator" with the ^
-.qhcp project file in %BUILDDIR%/qthelp, like this:
- echo.^> qcollectiongenerator %BUILDDIR%\qthelp\wheel.qhcp
- echo.To view the help file:
- echo.^> assistant -collectionFile %BUILDDIR%\qthelp\wheel.ghc
- goto end
-)
-
-if "%1" == "devhelp" (
- %SPHINXBUILD% -b devhelp %ALLSPHINXOPTS% %BUILDDIR%/devhelp
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished.
- goto end
-)
-
-if "%1" == "epub" (
- %SPHINXBUILD% -b epub %ALLSPHINXOPTS% %BUILDDIR%/epub
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The epub file is in %BUILDDIR%/epub.
- goto end
-)
-
-if "%1" == "latex" (
- %SPHINXBUILD% -b latex %ALLSPHINXOPTS% %BUILDDIR%/latex
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished; the LaTeX files are in %BUILDDIR%/latex.
- goto end
-)
-
-if "%1" == "text" (
- %SPHINXBUILD% -b text %ALLSPHINXOPTS% %BUILDDIR%/text
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The text files are in %BUILDDIR%/text.
- goto end
-)
-
-if "%1" == "man" (
- %SPHINXBUILD% -b man %ALLSPHINXOPTS% %BUILDDIR%/man
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The manual pages are in %BUILDDIR%/man.
- goto end
-)
-
-if "%1" == "texinfo" (
- %SPHINXBUILD% -b texinfo %ALLSPHINXOPTS% %BUILDDIR%/texinfo
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The Texinfo files are in %BUILDDIR%/texinfo.
- goto end
-)
-
-if "%1" == "gettext" (
- %SPHINXBUILD% -b gettext %I18NSPHINXOPTS% %BUILDDIR%/locale
- if errorlevel 1 exit /b 1
- echo.
- echo.Build finished. The message catalogs are in %BUILDDIR%/locale.
- goto end
-)
-
-if "%1" == "changes" (
- %SPHINXBUILD% -b changes %ALLSPHINXOPTS% %BUILDDIR%/changes
- if errorlevel 1 exit /b 1
- echo.
- echo.The overview file is in %BUILDDIR%/changes.
- goto end
-)
-
-if "%1" == "linkcheck" (
- %SPHINXBUILD% -b linkcheck %ALLSPHINXOPTS% %BUILDDIR%/linkcheck
- if errorlevel 1 exit /b 1
- echo.
- echo.Link check complete; look for any errors in the above output ^
-or in %BUILDDIR%/linkcheck/output.txt.
- goto end
-)
-
-if "%1" == "doctest" (
- %SPHINXBUILD% -b doctest %ALLSPHINXOPTS% %BUILDDIR%/doctest
- if errorlevel 1 exit /b 1
- echo.
- echo.Testing of doctests in the sources finished, look at the ^
-results in %BUILDDIR%/doctest/output.txt.
- goto end
-)
-
-:end
diff --git a/docs/story.rst b/docs/story.rst
deleted file mode 100644
index 2c150c2..0000000
--- a/docs/story.rst
+++ /dev/null
@@ -1,62 +0,0 @@
-The Story of Wheel
-==================
-
-I was impressed with Tarek’s packaging talk at PyCon 2010, and I
-admire PEP 345 (Metadata for Python Software Packages 1.2) and PEP 376
-(Database of Installed Python Distributions) which standardize a richer
-metadata format and show how distributions should be installed on disk. So
-naturally with all the hubbub about `packaging` in Python 3.3, I decided
-to try it to reap the benefits of a more standardized and predictable
-Python packaging experience.
-
-I began by converting `cryptacular`, a password hashing package which
-has a simple C extension, to use setup.cfg. I downloaded the Python 3.3
-source, struggled with the difference between setup.py and setup.cfg
-syntax, fixed the `define_macros` feature, stopped using the missing
-`extras` functionality, and several hours later I was able to generate my
-`METADATA` from `setup.cfg`. I rejoiced at my newfound freedom from the
-tyranny of arbitrary code execution during the build and install process.
-
-It was a lot of work. The package is worse off than before, and it can’t
-be built or installed without patching the Python source code itself.
-
-It was about that time that distutils-sig had a discussion about the
-need to include a generated setup.cfg from setup.cfg because setup.cfg
-wasn’t static enough. Wait, what?
-
-Of course there is a different way to massively simplify the install
-process. It’s called built or binary packages. You never have to run
-`setup.py` because there is no `setup.py`. There is only METADATA aka
-PKG-INFO. Installation has two steps: ‘build package’; ‘install
-package’, and you can skip the first step, have someone else do it
-for you, do it on another machine, or install the build system from a
-binary package and let the build system handle the building. The build
-is still complicated, but installation is simple.
-
-With the binary package strategy people who want to install use a simple,
-compatible installer, and people who want to package use whatever is
-convenient for them for as long as it meets their needs. No one has
-to rewrite `setup.py` for their own or the 20k+ other packages on PyPi
-unless a different build system does a better job.
-
-Wheel is my attempt to benefit from the excellent distutils-sig work
-without having to fix the intractable `distutils` software itself. Like
-METADATA and .dist-info directories but unlike Extension(), it’s
-simple enough that there really could be alternate implementations; the
-simplest (but less than ideal) installer is nothing more than “unzip
-archive.whl” somewhere on sys.path.
-
-If you’ve made it this far you probably wonder whether I’ve heard
-of eggs. Some comparisons:
-
-* Wheel is an installation format; egg is importable. Wheel archives do not need to include .pyc and are less tied to a specific Python version or implementation. Wheel can install (pure Python) packages built with previous versions of Python so you don’t always have to wait for the packager to catch up.
-
-* Wheel uses .dist-info directories; egg uses .egg-info. Wheel is compatible with the new world of Python `packaging` and the new concepts it brings.
-
-* Wheel has a richer file naming convention for today’s multi-implementation world. A single wheel archive can indicate its compatibility with a number of Python language versions and implementations, ABIs, and system architectures. Historically the ABI has been specific to a CPython release, but when we get a longer-term ABI, wheel will be ready.
-
-* Wheel is lossless. The first wheel implementation `bdist_wheel` always generates `egg-info`, and then converts it to a `.whl`. Later tools will allow for the conversion of existing eggs and bdist_wininst distributions.
-
-* Wheel is versioned. Every wheel file contains the version of the wheel specification and the implementation that packaged it. Hopefully the next migration can simply be to Wheel 2.0.
-
-I hope you will benefit from wheel.