summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-07-07 17:03:28 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2017-07-07 17:03:28 -0700
commit5076a511f1444b3520ca37ed22aa692f6fd49305 (patch)
tree2282942b995cb284cc42adb3a41493e6af37f358
parent2bcf2fe16602b3393e3324436a88f9887161235e (diff)
downloadwheel-5076a511f1444b3520ca37ed22aa692f6fd49305.tar.gz
Document support for Python 3.6 and add it to the testing matrix
Drops support for Python 2.6. Remove now unnecessary import workarounds. Add missing trove classifiers.
-rw-r--r--CHANGES.txt1
-rw-r--r--METADATA.in8
-rw-r--r--setup.py29
-rw-r--r--tox.ini2
-rw-r--r--wheel/bdist_wheel.py6
-rw-r--r--wheel/metadata.py5
-rw-r--r--wheel/pep425tags.py6
-rw-r--r--wheel/util.py5
8 files changed, 26 insertions, 36 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 5e40718..dfbb12b 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -6,6 +6,7 @@
- Much improved use of context managers for file handling. Thanks Kyle
Stewart.
- Convert absolute imports to relative. Thanks Ashish Bhate.
+- Remove support for Python 2.6.
0.29.0
======
diff --git a/METADATA.in b/METADATA.in
index 2827551..18ebf32 100644
--- a/METADATA.in
+++ b/METADATA.in
@@ -8,16 +8,20 @@ Author-email: dholth@fastmail.fm
License: MIT
Keywords: wheel,packaging
Platform: UNKNOWN
-Classifier: Development Status :: 4 - Beta
+Classifier: Development Status :: 5 - Production/Stable
Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: MIT License
Classifier: Programming Language :: Python
Classifier: Programming Language :: Python :: 2
-Classifier: Programming Language :: Python :: 2.6
Classifier: Programming Language :: Python :: 2.7
Classifier: Programming Language :: Python :: 3
Classifier: Programming Language :: Python :: 3.2
Classifier: Programming Language :: Python :: 3.3
Classifier: Programming Language :: Python :: 3.4
+Classifier: Programming Language :: Python :: 3.5
+Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: Implementation :: CPython
+Classifier: Programming Language :: Python :: Implementation :: PyPy
Provides-Extra: tool
Provides-Extra: signatures
Requires-Dist: keyring; extra == 'signatures'
diff --git a/setup.py b/setup.py
index bd1c900..cde619a 100644
--- a/setup.py
+++ b/setup.py
@@ -15,17 +15,21 @@ setup(name='wheel',
description='A built-package format for Python.',
long_description=README + '\n\n' + CHANGES,
classifiers=[
- "Development Status :: 4 - Beta",
- "Intended Audience :: Developers",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
- "Programming Language :: Python :: 3.3",
- "Programming Language :: Python :: 3.4",
- ],
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ ],
author='Daniel Holth',
author_email='dholth@fastmail.fm',
url='https://bitbucket.org/pypa/wheel/',
@@ -38,10 +42,8 @@ setup(name='wheel',
'wheel.signatures'
],
extras_require={
- ':python_version=="2.6"': ['argparse'],
'signatures': ['keyring', 'keyrings.alt'],
'signatures:sys_platform!="win32"': ['pyxdg'],
- 'signatures:python_version=="2.6"': ['importlib'],
'faster-signatures': ['ed25519ll'],
'tool': []
},
@@ -57,4 +59,3 @@ setup(name='wheel',
]
}
)
-
diff --git a/tox.ini b/tox.ini
index 9590ab4..309d58d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, pypy, py33, py34, py35
+envlist = py27, pypy, py33, py34, py35, py36
[testenv]
commands =
diff --git a/wheel/bdist_wheel.py b/wheel/bdist_wheel.py
index edbba05..dfcc910 100644
--- a/wheel/bdist_wheel.py
+++ b/wheel/bdist_wheel.py
@@ -14,12 +14,6 @@ import json
import sys
import re
-try:
- import sysconfig
-except ImportError: # pragma nocover
- # Python < 2.7
- import distutils.sysconfig as sysconfig
-
import pkg_resources
safe_name = pkg_resources.safe_name
diff --git a/wheel/metadata.py b/wheel/metadata.py
index 341c4b0..2b123f9 100644
--- a/wheel/metadata.py
+++ b/wheel/metadata.py
@@ -5,10 +5,7 @@ Tools for converting old- to new-style metadata.
from collections import namedtuple
from .pkginfo import read_pkg_info
from .util import OrderedDefaultDict
-try:
- from collections import OrderedDict
-except ImportError:
- OrderedDict = dict
+from collections import OrderedDict
import re
import os.path
diff --git a/wheel/pep425tags.py b/wheel/pep425tags.py
index 49a1367..a7bd4a9 100644
--- a/wheel/pep425tags.py
+++ b/wheel/pep425tags.py
@@ -3,11 +3,7 @@
import sys
import warnings
-try:
- import sysconfig
-except ImportError: # pragma nocover
- # Python < 2.7
- import distutils.sysconfig as sysconfig
+import sysconfig
import distutils.util
diff --git a/wheel/util.py b/wheel/util.py
index 5268813..20f386f 100644
--- a/wheel/util.py
+++ b/wheel/util.py
@@ -5,10 +5,7 @@ import os
import base64
import json
import hashlib
-try:
- from collections import OrderedDict
-except ImportError:
- OrderedDict = dict
+from collections import OrderedDict
__all__ = ['urlsafe_b64encode', 'urlsafe_b64decode', 'utf8',
'to_json', 'from_json', 'matches_requirement']