summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-01-11 14:30:30 +0200
committerGitHub <noreply@github.com>2022-01-11 14:30:30 +0200
commit23e47ba455d2c4345bb82ff2760006a780eb0f23 (patch)
treeb7d5dcf4462baf75fc8ea67f8a328cc3790a821f
parent4f6ba78fede38a8d9e35a14e38377a121033afb3 (diff)
parentab82cea0d809968f9e558da06c4b772d1bbd5506 (diff)
downloadwheel-git-flit-backend.tar.gz
Merge branch 'main' into flit-backendflit-backend
-rw-r--r--.gitignore1
-rw-r--r--.pre-commit-config.yaml2
-rw-r--r--docs/quickstart.rst5
-rw-r--r--docs/user_guide.rst6
4 files changed, 7 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
index 86d063f..54defeb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,7 +3,6 @@
*.pyc
*.so
*.dll
-*.dylib
build
dist
docs/_build
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 3af1a3e..2ead1fe 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -24,7 +24,7 @@ repos:
args: ["-a", "from __future__ import annotations"]
- repo: https://github.com/asottile/pyupgrade
- rev: v2.30.1
+ rev: v2.31.0
hooks:
- id: pyupgrade
args: ["--py37-plus"]
diff --git a/docs/quickstart.rst b/docs/quickstart.rst
index a8fe813..13c16a3 100644
--- a/docs/quickstart.rst
+++ b/docs/quickstart.rst
@@ -1,9 +1,10 @@
Quickstart
==========
-To build a wheel for your setuptools based project::
+To build a wheel for your project::
- python setup.py bdist_wheel
+ python -m pip install build
+ python -m build --wheel
The wheel will go to ``dist/yourproject-<tags>.whl``.
diff --git a/docs/user_guide.rst b/docs/user_guide.rst
index 6517258..c8b5a34 100644
--- a/docs/user_guide.rst
+++ b/docs/user_guide.rst
@@ -4,9 +4,10 @@ User Guide
Building Wheels
---------------
-Building wheels from a setuptools_ based project is simple::
+To build a wheel for your project::
- python setup.py bdist_wheel
+ python -m pip install build
+ python -m build --wheel
This will build any C extensions in the project and then package those and the
pure Python code into a ``.whl`` file in the ``dist`` directory.
@@ -20,7 +21,6 @@ adding this to your ``setup.cfg`` file:
[bdist_wheel]
universal = 1
-.. _setuptools: https://pypi.org/project/setuptools/
Including license files in the generated wheel file
---------------------------------------------------