summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Smith <smithdc@gmail.com>2020-11-07 21:21:49 +0000
committerDavid Smith <smithdc@gmail.com>2020-11-07 21:21:49 +0000
commit548990c937b8e1aee66e3530975c424cc9a02163 (patch)
tree81f1560023cbc0e43f7a7b13d45665f1c02e1e0f
parentd5df159bd27b41c77042e8814ab4f37ebdcea18a (diff)
downloadwebtest-548990c937b8e1aee66e3530975c424cc9a02163.tar.gz
Updated travis, setup.py and changelog.rst
-rw-r--r--.travis.yml4
-rw-r--r--CHANGELOG.rst2
-rw-r--r--setup.py6
3 files changed, 2 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index ef65b16..fd8ba29 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,10 +2,6 @@ language: python
matrix:
include:
- - python: 2.7
- env: TOXENV=py27
- - python: 3.5
- env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
- python: 3.7
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 612e2cc..0c7dcba 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -4,7 +4,7 @@ News
2.0.36 (unreleased)
-------------------
-- Nothing changed yet.
+- Dropped support for Python 2.7 and 3.5.
2.0.35 (2020-04-27)
diff --git a/setup.py b/setup.py
index fd24963..90202a6 100644
--- a/setup.py
+++ b/setup.py
@@ -6,14 +6,13 @@ from setuptools import find_packages
version = '2.0.36.dev0'
install_requires = [
- 'six',
'WebOb>=1.2',
'waitress>=0.8.5',
'beautifulsoup4',
]
tests_require = [
- 'nose<1.3.0', 'coverage', 'mock',
+ 'nose<1.3.0', 'coverage',
'PasteDeploy', 'WSGIProxy2', 'pyquery'
]
@@ -34,10 +33,7 @@ setup(name='WebTest',
"License :: OSI Approved :: MIT License",
"Topic :: Internet :: WWW/HTTP :: WSGI",
"Topic :: Internet :: WWW/HTTP :: WSGI :: Server",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",