summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Piercy <web@stevepiercy.com>2020-11-13 00:21:49 -0800
committerSteve Piercy <web@stevepiercy.com>2020-11-13 00:21:49 -0800
commit3fd3f1bc99fa117dd7a756a7985d8794515426c9 (patch)
tree28136cf270ce12efe1d4e546d9832efb81eab48b
parent7c4fce298b1e7e2af1aa062e3eb0181db3b967e0 (diff)
downloadwebtest-3fd3f1bc99fa117dd7a756a7985d8794515426c9.tar.gz
Install pytest-cov
Remove remnants of nosetests and replace with pytest
-rw-r--r--docs/contributing.rst2
-rw-r--r--setup.cfg12
-rw-r--r--setup.py2
3 files changed, 2 insertions, 14 deletions
diff --git a/docs/contributing.rst b/docs/contributing.rst
index 9d2a7bb..f2acbbb 100644
--- a/docs/contributing.rst
+++ b/docs/contributing.rst
@@ -23,7 +23,7 @@ Execute tests
.. code-block:: bash
- $ bin/nosetests
+ $ bin/pytest
Doctest: forms.rst ... ok
Doctest: index.rst ... ok
diff --git a/setup.cfg b/setup.cfg
index a3fb803..48413f8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -4,18 +4,6 @@ dev = develop easy_install webtest[tests]
[bdist_wheel]
universal=0
-[nosetests]
-verbosity=2
-detailed-errors = True
-with-doctest = True
-doctest-extension = rst
-doctest-fixtures = _fixt
-# XXX: docs/index.rst requires lxml
-include = docs
-exclude = (CHANGELOG|changelog|contributing).rst
-cover-package=webtest
-doctest-options = +ELLIPSIS,+NORMALIZE_WHITESPACE
-
[tool:pytest]
addopts = -p no:warnings
--doctest-modules
diff --git a/setup.py b/setup.py
index 73da336..bb698e8 100644
--- a/setup.py
+++ b/setup.py
@@ -16,6 +16,7 @@ tests_require = [
'PasteDeploy',
'pyquery',
'pytest',
+ 'pytest-cov',
'WSGIProxy2',
]
@@ -60,7 +61,6 @@ setup(name='WebTest',
zip_safe=False,
python_requires='>=3.6, <4',
install_requires=install_requires,
- test_suite='nose.collector',
tests_require=tests_require,
extras_require={
'tests': tests_require,