summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt6
-rw-r--r--docs/TODO9
-rw-r--r--docs/notes11
-rw-r--r--docs/release.txt2
-rw-r--r--setup.py2
5 files changed, 19 insertions, 11 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 1480a3c..b5b8dbd 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,6 +1,12 @@
Changes
=======
+0.4.0 - Mar 12, 2013
+--------------------
+
+ * ***NOTE*** : 0.5.0 will drop Hixie protocol support
+ * use Buffer base64 support in Node.js implementation
+
0.3.0 - Jan 15, 2013
--------------------
diff --git a/docs/TODO b/docs/TODO
index cc4b477..7fca9d1 100644
--- a/docs/TODO
+++ b/docs/TODO
@@ -1,9 +1,6 @@
- Go implementation
-
-- Support multiple targets that are selected by the path line. Some
- sort of wildcarding of ports too.
-
-- Support SSL targets too.
-
+- Rust implementation
+- Add sub-protocol support to upstream einaros/ws module and use that
+ instead of the patched module.
- wstelnet: support CSI L and CSI M
diff --git a/docs/notes b/docs/notes
index b3cc0cf..e340375 100644
--- a/docs/notes
+++ b/docs/notes
@@ -13,5 +13,12 @@ browser.
Building web-socket-js emulator:
-cd include/web-socket-js/flash-src
-mxmlc -static-link-runtime-shared-libraries WebSocketMain.as
+ cd include/web-socket-js/flash-src
+ mxmlc -static-link-runtime-shared-libraries WebSocketMain.as
+
+Building release tarball:
+ - not really necessary since tagged revision can be downloaded
+ from github as tarballs
+
+ git archive --format=tar --prefix=websockify-${WVER}/ v${WVER} > websockify-${WVER}.tar
+ gzip websockify-${WVER}.tar
diff --git a/docs/release.txt b/docs/release.txt
index 611d4eb..e0e2660 100644
--- a/docs/release.txt
+++ b/docs/release.txt
@@ -4,8 +4,6 @@
git tag v${WVER}
git push origin master
git push origin v${WVER}
- git archive --format=tar --prefix=websockify-${WVER}/ v${WVER} > websockify-${WVER}.tar
- gzip websockify-${WVER}.tar
- Register with pypi.python.org (once):
python setup.py register
- Upload the source distribution to pypi
diff --git a/setup.py b/setup.py
index ab44ef7..5794bda 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.3.0'
+version = '0.4.0'
name = 'websockify'
long_description = open("README.md").read() + "\n" + \
open("CHANGES.txt").read() + "\n"