summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCédric de Saint Martin <cedric.dsm@tiolive.com>2012-02-18 09:43:12 +0100
committerCédric de Saint Martin <cedric.dsm@tiolive.com>2012-02-18 09:43:12 +0100
commit301f3ae580557da47fa5ea2050aa671ce9c5a1a0 (patch)
tree6d686b336cc723fb9e93bef0603f5e7e1b20ef63 /setup.py
parentdb171519411a126b0eecc0b1f925516e7d7c82fd (diff)
downloadwebsockify-301f3ae580557da47fa5ea2050aa671ce9c5a1a0.tar.gz
Eggify websockify
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..095c653
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+version = '0.1-dev'
+name = 'websockify'
+long_description = open("README.md").read() + "\n" + \
+ open("CHANGES.txt").read() + "\n"
+
+setup(name=name,
+ version=version,
+ description="Websockify.",
+ long_description=long_description,
+ classifiers=[
+ "Programming Language :: Python",
+ ],
+ keywords='noVNC websockify',
+ license='LGPLv3',
+ url="https://github.com/kanaka/websockify",
+ author="Joel Martin",
+ author_email="github@martintribe.org",
+
+ packages=find_packages(),
+ include_package_data=True,
+ install_requires=['numpy'],
+ zip_safe=False,
+ entry_points={
+ 'console_scripts': [
+ 'websockify = websockify:websockify_init',
+ ]
+ },
+ )