summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoel Martin <github@martintribe.org>2010-06-04 17:10:06 -0500
committerJoel Martin <github@martintribe.org>2010-06-04 17:10:06 -0500
commit8e1aa95ba31b9b7596df604a97a06bebc14da279 (patch)
tree5c785ce7019c7f1a79e1d82d59f6fb17d66c822e /Makefile
parent14355cb212fe690f8192f41aa4f67ea9a91d2ddd (diff)
downloadwebsockify-8e1aa95ba31b9b7596df604a97a06bebc14da279.tar.gz
First pass at working C wsproxy.
No sequence numbering and only support b64encoding at the moment.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..bd824f8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+wsproxy: wsproxy.o websocket.o
+ $(CC) $^ -l ssl -l resolv -o $@
+
+#websocket.o: websocket.c
+# $(CC) -c $^ -o $@
+#
+#wsproxy.o: wsproxy.c
+# $(CC) -c $^ -o $@
+
+clean:
+ rm -f wsproxy wsproxy.o websocket.o
+