summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoel Martin <github@martintribe.org>2011-01-12 18:09:54 -0600
committerJoel Martin <github@martintribe.org>2011-01-12 18:09:54 -0600
commit6d1e216115d5ab84dafed0c91c40f58f7857c877 (patch)
treef31b592d73b1ec35736097c542d2ea51e6861d8b /Makefile
parent932e7318b93ecbb59bdf6c22917cc70e03831d86 (diff)
downloadwebsockify-6d1e216115d5ab84dafed0c91c40f58f7857c877.tar.gz
fork noVNC, rename to websockify, cleanup.
Split of wsproxy from noVNC and rename it websockify.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..7dc1bc4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,11 @@
+TARGETS=rebind.so
+CFLAGS += -fPIC
+
+all: $(TARGETS)
+
+rebind.so: rebind.o
+ $(CC) $(LDFLAGS) $^ -shared -fPIC -ldl -o $@
+
+clean:
+ rm -f rebind.o rebind.so
+