summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSolly Ross <sross@redhat.com>2015-05-13 17:07:47 -0400
committerSolly Ross <sross@redhat.com>2015-07-23 21:02:37 -0400
commit69c04c819c53556b72e0c6c82d12080a9784f364 (patch)
treed82b13d5c0a70ab8e1ea80bbf6f18de5507a4a37
parent558a6439f14b0d85a31145541745e25c255d576b (diff)
downloadwebsockify-0.7.0.tar.gz
Update to 0.7.0v0.7.0
See CHANGES.txt for details.
-rw-r--r--CHANGES.txt17
-rw-r--r--other/js/package.json2
-rw-r--r--setup.py2
3 files changed, 19 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 76a5c55..51feefa 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,6 +1,23 @@
Changes
=======
+0.7.0
+-----
+
+* Python 3 support fixes (#140, #155, #159)
+* Generic token-parsing plugins support (#162)
+* Generic authentication plugins support (#172)
+* Fixed frame corruption on big-endian systems (#161)
+* Support heartbeats (via PING) and automatic responses to PONG (#169)
+* Automatically reject unmasked client frames by default (strict mode) (#174)
+* Automatically restart interrupted select calls (#175)
+* Make 'run' respect environment settings (including virtualenv) (#176)
+
+0.6.1 - May 11, 2015
+--------------------
+
+* **PATCH RELEASE**: Fixes a bug causing file_only to not be passed properly
+
0.6.0 - Feb 18, 2014
--------------------
diff --git a/other/js/package.json b/other/js/package.json
index ef48920..6189e9e 100644
--- a/other/js/package.json
+++ b/other/js/package.json
@@ -3,7 +3,7 @@
"name": "websockify",
"description": "websockify is a WebSocket-to-TCP proxy/bridge",
"license": "LGPL-3",
- "version": "0.6.0",
+ "version": "0.7.0",
"repository": {
"type": "git",
"url": "git://github.com/kanaka/websockify.git"
diff --git a/setup.py b/setup.py
index 8a2f239..0ba28c8 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.6.0'
+version = '0.7.0'
name = 'websockify'
long_description = open("README.md").read() + "\n" + \
open("CHANGES.txt").read() + "\n"