summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSolly Ross <sross@redhat.com>2015-05-06 14:29:51 -0400
committerSolly Ross <sross@redhat.com>2015-05-12 12:53:43 -0400
commitafb5d2801fd477411dad13bf974e36631bc1c5b7 (patch)
tree06ef2164bbd4fc2476e35e4dc55eb43462a0cedf
parent52f6830852216fc80ab2505b0ca0f5bbcd450d5a (diff)
downloadwebsockify-feature/generic-auth-hook.tar.gz
This commit enables running the unit tests on Travis for Python 2.6, 2.7, 3.3, and 3.4. Note that Travis does not support Python 2.4, so we cannot test there.
-rw-r--r--.travis.yml10
-rw-r--r--test-requirements.txt2
-rw-r--r--tox.ini6
3 files changed, 14 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..4aced3a
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,10 @@
+language: python
+python:
+ - 2.6
+ - 2.7
+ - 3.3
+ - 3.4
+
+install: pip install -r test-requirements.txt
+
+script: python setup.py nosetests --verbosity=3
diff --git a/test-requirements.txt b/test-requirements.txt
new file mode 100644
index 0000000..93207c1
--- /dev/null
+++ b/test-requirements.txt
@@ -0,0 +1,2 @@
+mox
+nose
diff --git a/tox.ini b/tox.ini
index 012d349..79f7201 100644
--- a/tox.ini
+++ b/tox.ini
@@ -8,12 +8,10 @@ envlist = py24,py26,py27,py33,py34
[testenv]
commands = nosetests {posargs}
-deps =
- mox
- nose
+deps = -r{toxinidir}/test-requirements.txt
# At some point we should enable this since tox expects it to exist but
-# the code will need pep8ising first.
+# the code will need pep8ising first.
#[testenv:pep8]
#commands = flake8
#dep = flake8