summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog9
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--websocket/__init__.py2
4 files changed, 12 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 17a647a..c6b5548 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,15 @@
ChangeLog
============
+- 1.0.0
+
+ - Removed Python 2 code, now only Python 3 compatible (d45343b, b7c5733, ff67af8)
+ - Use semver for release versions, unlike breaking release 0.58.0 (#669)
+ - Enhance enableTrace output (13e83b4)
+ - Improve unit tests to over 80% code coverage (1679ab0, a00dd2d, etc.)
+ - Fix old _app.py close status code bug (#686)
+ - Replace select import with selectors (#568)
+
- 0.59.0
- Last main release to support Python 2
diff --git a/docs/source/conf.py b/docs/source/conf.py
index f7f5c57..44bf906 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2021'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '0.59.0'
+release = '1.0.0'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index 4cf6ab1..55a8635 100644
--- a/setup.py
+++ b/setup.py
@@ -27,7 +27,7 @@ import sys
from setuptools import setup
import pkg_resources
-VERSION = "0.59.0"
+VERSION = "1.0.0"
install_requires = []
tests_require = []
diff --git a/websocket/__init__.py b/websocket/__init__.py
index f2c7b44..38da7b3 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -25,4 +25,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "0.59.0"
+__version__ = "1.0.0"