summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml3
-rw-r--r--README.rst8
-rw-r--r--setup.py13
3 files changed, 16 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 7a9000f..eff4b4a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,9 +2,10 @@ language: python
python:
- '2.7'
- - '3.3'
- '3.4'
- '3.5'
+ - '3.6'
+ - '3.7-dev'
- 'pypy'
- 'nightly'
diff --git a/README.rst b/README.rst
index ba7a36c..3c96af0 100644
--- a/README.rst
+++ b/README.rst
@@ -15,15 +15,15 @@ License
Installation
=============
-This module is tested on Python 2.7 and Python 3.x.
+This module is tested on Python 2.7 and Python 3.4+.
Type "python setup.py install" or "pip install websocket-client" to install.
.. CAUTION::
- from v0.16.0, we can install by "pip install websocket-client" for python 3.
+ from v0.16.0, we can install by "pip install websocket-client" for Python 3.
-This module depend on
+This module depends on
- six
- backports.ssl_match_hostname for Python 2.x
@@ -38,7 +38,7 @@ You can get the best performance from numpy.
How about Python 3
===========================
-Now, we support python 3 on single source code from version 0.14.0. Thanks, @battlemidget and @ralphbean.
+Now, we support Python 3 on single source code from version 0.14.0. Thanks, @battlemidget and @ralphbean.
HTTP Proxy
=============
diff --git a/setup.py b/setup.py
index 1e3ddc9..15db869 100644
--- a/setup.py
+++ b/setup.py
@@ -12,12 +12,12 @@ tests_require = []
if sys.version_info[0] == 2 and sys.version_info[1] < 7:
tests_require.append('unittest2==0.8.0')
-insecure_pythons = '2.4, 2.5, 2.6, ' + ', '.join("2.7.{pv}".format(pv=pv) for pv in range(10))
+insecure_pythons = '2.6, ' + ', '.join("2.7.{pv}".format(pv=pv) for pv in range(10))
extras_require = {
':python_version in "{ips}"'.format(ips=insecure_pythons):
['backports.ssl_match_hostname'],
- ':python_version in "2.4, 2.5, 2.6"': ['argparse'],
+ ':python_version in "2.6"': ['argparse'],
}
try:
@@ -38,18 +38,25 @@ except Exception:
setup(
name=NAME,
version=VERSION,
- description="WebSocket client for python. hybi13 is supported.",
+ description="WebSocket client for Python. hybi13 is supported.",
long_description=open("README.rst").read(),
author="liris",
author_email="liris.pp@gmail.com",
license="LGPL",
url="https://github.com/websocket-client/websocket-client.git",
+ python_requires='>=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
classifiers=[
"Development Status :: 4 - Beta",
"License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
"Operating System :: MacOS :: MacOS X",
"Operating System :: POSIX",
"Operating System :: Microsoft :: Windows",