summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml14
1 files changed, 14 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..bf28117
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,14 @@
+language: python
+
+python:
+ - '2.7'
+ - '3.3'
+ - '3.4'
+ - 'pypy'
+ - 'nightly'
+
+install:
+ - python -c "import setuptools; print(setuptools.__version__)"
+
+script:
+ - TEST_WITH_INTERNET=1 python setup.py test