summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2022-02-25 15:55:07 -0500
committerengn33r <engn33r@users.noreply.github.com>2022-02-25 15:55:07 -0500
commitdb1f2cca25d9ca5c91ad678d04bada730a77ecdf (patch)
treeed100f8708531ac0ee3633e8c6c1ca579209cc66
parentc123c3c735309863c1a9f086662cf9a3f1c0e649 (diff)
downloadwebsocket-client-db1f2cca25d9ca5c91ad678d04bada730a77ecdf.tar.gz
1.3.1v1.3.1
-rw-r--r--ChangeLog5
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--upload.sh4
-rw-r--r--websocket/__init__.py2
5 files changed, 12 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 0d81c38..29a9809 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,11 @@
ChangeLog
============
+- 1.3.1
+ - Fix 10 year old bug and improve dispatcher handling for run_forever (#795)
+ - Fix run_forever to never return None, only return True or False, and add two tests (#788)
+ - Remove Python 3.6 support, EOL in Dec 2021
+
- 1.3.0
- BREAKING: Set Origin header to use https:// scheme when wss:// WebSocket URL is passed (#787)
- Replace deprecated/broken WebSocket URLs with working ones (6ad5197)
diff --git a/docs/source/conf.py b/docs/source/conf.py
index e147366..f9659f8 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2022'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '1.3.0'
+release = '1.3.1'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index d58cb3e..420b66e 100644
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ import sys
from setuptools import setup, find_packages
import pkg_resources
-VERSION = "1.3.0"
+VERSION = "1.3.1"
install_requires = []
tests_require = []
diff --git a/upload.sh b/upload.sh
index c9e547b..5b2da2e 100644
--- a/upload.sh
+++ b/upload.sh
@@ -25,3 +25,7 @@ twine upload --repository testpypi dist/*
# Then pass __token__ as the username and the token value as password
# https://packaging.python.org/en/latest/tutorials/packaging-projects/#uploading-the-distribution-archives
twine upload dist/*
+
+# Clean up
+# Delete the build/, dist/, and websocket_client.egg-info/ directories
+rm -r build dist websocket_client.egg-info
diff --git a/websocket/__init__.py b/websocket/__init__.py
index f8cc4f9..7b6c24e 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -23,4 +23,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "1.3.0"
+__version__ = "1.3.1"