summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2022-11-03 00:00:00 +0000
committerengn33r <engn33r@users.noreply.github.com>2022-11-03 00:00:00 +0000
commitc8c5a19da2a2015a64d08479e74779de7fd355de (patch)
tree315acb2853e3de6c782833dbf2c9d8863099f1c3
parente7445f8e8629530cb3491c020295986606d8dbd8 (diff)
downloadwebsocket-client-c8c5a19da2a2015a64d08479e74779de7fd355de.tar.gz
1.4.2v1.4.2
-rw-r--r--ChangeLog5
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--websocket/__init__.py2
4 files changed, 8 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index b80d594..409041a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,11 @@
ChangeLog
============
+- 1.4.2
+ - create_dispatcher is determined by URL ws/wss, NOT by presence of sslopt args, to maintain consistency (#875)
+ - Remove redundant key generation line (#864)
+ - Updated docs to fix old links and updated CI to include Python 3.11
+
- 1.4.1
- Fix stack growth bug when `run_forever` reconnects (#854)
- Add doctest CI for sphinx docs code examples (d150099)
diff --git a/docs/source/conf.py b/docs/source/conf.py
index 1d49533..a07281f 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2022'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '1.4.1'
+release = '1.4.2'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index 0180453..cb14d1c 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ See the License for the specific language governing permissions and
limitations under the License.
"""
-VERSION = "1.4.1"
+VERSION = "1.4.2"
install_requires = []
tests_require = []
diff --git a/websocket/__init__.py b/websocket/__init__.py
index 720a842..588a8f2 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -23,4 +23,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "1.4.1"
+__version__ = "1.4.2"