summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2022-03-29 00:00:00 +0000
committerengn33r <engn33r@users.noreply.github.com>2022-03-29 00:00:00 +0000
commitc2625f99789ad71f5295b86a1d2e2217ee2c5886 (patch)
treeb8141d040149975dd0a5b17f1788dbf0bbf4a730
parente6a09d6e02cf8293fb3243a859e0dd7b1dbe305c (diff)
downloadwebsocket-client-c2625f99789ad71f5295b86a1d2e2217ee2c5886.tar.gz
1.3.2v1.3.2
-rw-r--r--ChangeLog6
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--websocket/__init__.py2
4 files changed, 9 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 29a9809..1910036 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,12 @@
ChangeLog
============
+- 1.3.2
+ - Add support for pre-initialized stream socket in new WebSocketApp (#804)
+ - Remove rel.saferead() in examples (f0bf03d)
+ - Increase scope of linting checks (dca4022)
+ - Start adding type hints (a8a4099)
+
- 1.3.1
- Fix 10 year old bug and improve dispatcher handling for run_forever (#795)
- Fix run_forever to never return None, only return True or False, and add two tests (#788)
diff --git a/docs/source/conf.py b/docs/source/conf.py
index f9659f8..a5d57ad 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2022'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '1.3.1'
+release = '1.3.2'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index c33f07b..3164e60 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ See the License for the specific language governing permissions and
limitations under the License.
"""
-VERSION = "1.3.1"
+VERSION = "1.3.2"
install_requires = []
tests_require = []
diff --git a/websocket/__init__.py b/websocket/__init__.py
index 7b6c24e..a5a3950 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -23,4 +23,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "1.3.1"
+__version__ = "1.3.2"