summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2023-01-26 00:00:00 +0000
committerengn33r <engn33r@users.noreply.github.com>2023-01-26 00:00:00 +0000
commit91b76c8b1b34d08b56bc7e27fffd8e194174b5ba (patch)
tree350fc75bf0e670f1656ee39353dd3b0023cf05a1
parent8af1cbb17f5f12c9999fc56adf7b0187a1714174 (diff)
downloadwebsocket-client-91b76c8b1b34d08b56bc7e27fffd8e194174b5ba.tar.gz
1.5.0v1.5.0
-rw-r--r--ChangeLog7
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--websocket/__init__.py2
4 files changed, 10 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 409041a..e791ab8 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,13 @@
ChangeLog
============
+- 1.5.0
+ - Refactor and improve ping/pong logic to resolve several issues, including an infinite loop issue during reconnect (#862)
+ - Fix issue where `skip_utf8_validation = True` is ignored (#886)
+ - Fix issue where sslopt `is_ssl` is ignored (#875)
+ - Downgrade "websocket connected" message from logging.warning to logging.info (#888)
+ - Update github actions to newer versions (669fe1b)
+
- 1.4.2
- create_dispatcher is determined by URL ws/wss, NOT by presence of sslopt args, to maintain consistency (#875)
- Remove redundant key generation line (#864)
diff --git a/docs/source/conf.py b/docs/source/conf.py
index a07281f..0f1de30 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2022'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '1.4.2'
+release = '1.5.0'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index cb14d1c..e617322 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ See the License for the specific language governing permissions and
limitations under the License.
"""
-VERSION = "1.4.2"
+VERSION = "1.5.0"
install_requires = []
tests_require = []
diff --git a/websocket/__init__.py b/websocket/__init__.py
index 588a8f2..42b6c87 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -23,4 +23,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "1.4.2"
+__version__ = "1.5.0"